aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-01-05 15:10:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-01-05 20:05:33 +0100
commite9929ebeeaef5f59d56b93ebe96c9fc0bd363521 (patch)
treecb4af99656d725fedd15f7eae0eab498ac6f20d4
parentdc399c4e120ac71ed406b44036c60ef90778ea52 (diff)
downloadupstream-e9929ebeeaef5f59d56b93ebe96c9fc0bd363521.tar.gz
upstream-e9929ebeeaef5f59d56b93ebe96c9fc0bd363521.tar.bz2
upstream-e9929ebeeaef5f59d56b93ebe96c9fc0bd363521.zip
ramips: Fix sysupgrade for Xiaomi mir3g
Without this change sysupgrade from 18.06 to 19.07 is only possible with the -F option. In OpenWrt 18.06 the nand_do_platform_check() function is called with the board name mir3g only, if the tar does not use mir3g it will fail. OpenWrt 19.07 and later support the metadata with the supported_devices attribute to allow renaming. Do the renaming of the target between 19.07 and master like it is done for some other boards. I tested the following sysupgrades successfully without -F 18.06 -> 19.07 19.07 -> master master -> 19.07 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/ramips/image/mt7621.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 7eb59188fb..39017a48e1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -269,7 +269,7 @@ define Device/xiaomi_mir3p
endef
TARGET_DEVICES += xiaomi_mir3p
-define Device/xiaomi_mir3g
+define Device/mir3g
DTS := MIR3G
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -282,12 +282,12 @@ define Device/xiaomi_mir3g
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_TITLE := Xiaomi Mi Router 3G
SUPPORTED_DEVICES += R3G
- SUPPORTED_DEVICES += mir3g
+ SUPPORTED_DEVICES += xiaomi,mir3g
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
uboot-envtools
endef
-TARGET_DEVICES += xiaomi_mir3g
+TARGET_DEVICES += mir3g
define Device/mt7621
DTS := MT7621