aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-06 17:14:43 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-12 10:32:54 +0100
commit6ac1aa19579ddbee922ea5b89d7398f527baabd8 (patch)
treee855f4e795e6af012fe7173b391d48fadb030c0e
parent5e1864da3364c9edb9af783c37e584d0337ec28e (diff)
downloadupstream-6ac1aa19579ddbee922ea5b89d7398f527baabd8.tar.gz
upstream-6ac1aa19579ddbee922ea5b89d7398f527baabd8.tar.bz2
upstream-6ac1aa19579ddbee922ea5b89d7398f527baabd8.zip
kernel: bump 4.14 to 4.14.152
Refreshed all patches. Altered patches: - 301-arch-support-layerscape.patch Remove upstreamed: - 950-0311-sc16is7xx-Fix-for-Unexpected-interrupt-8.patch Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch2
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0311-sc16is7xx-Fix-for-Unexpected-interrupt-8.patch110
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch4
-rw-r--r--target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch4
-rw-r--r--target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch13
6 files changed, 13 insertions, 124 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index fa4134e7c5..859928fb38 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .151
+LINUX_VERSION-4.14 = .152
-LINUX_KERNEL_HASH-4.14.151 = ff519c428ee9bbb513a84db5ec32a7e3705cd8c23a57104b25b944cb79583fae
+LINUX_KERNEL_HASH-4.14.152 = a9239fd9d341aae07b48a8e7a2afd528fe5cde2617d783454c71e6f3dae2b0aa
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
index a1bc0c2c07..14dae14a12 100644
--- a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
@@ -841,7 +841,7 @@ Signed-off-by: Malik Olivier Boussejra <malik@boussejra.com>
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -5098,7 +5098,7 @@ static void port_event(struct usb_hub *h
+@@ -5105,7 +5105,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;
diff --git a/target/linux/brcm2708/patches-4.14/950-0311-sc16is7xx-Fix-for-Unexpected-interrupt-8.patch b/target/linux/brcm2708/patches-4.14/950-0311-sc16is7xx-Fix-for-Unexpected-interrupt-8.patch
deleted file mode 100644
index b01e523a1e..0000000000
--- a/target/linux/brcm2708/patches-4.14/950-0311-sc16is7xx-Fix-for-Unexpected-interrupt-8.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From d4601b298709e44a998df772ac1c85707603fde4 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.org>
-Date: Fri, 18 May 2018 10:26:59 +0100
-Subject: [PATCH 311/454] sc16is7xx: Fix for "Unexpected interrupt: 8"
-
-The SC16IS752 has an Enhanced Feature Register which is aliased at the
-same address as the Interrupt Identification Register; accessing it
-requires that a magic value is written to the Line Configuration
-Register. If an interrupt is raised while the EFR is mapped in then
-the ISR won't be able to access the IIR, leading to the "Unexpected
-interrupt" error messages.
-
-Avoid the problem by claiming a mutex around accesses to the EFR
-register, also claiming the mutex in the interrupt handler work
-item (this is equivalent to disabling interrupts to interlock against
-a non-threaded interrupt handler).
-
-See: https://github.com/raspberrypi/linux/issues/2529
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.org>
----
- drivers/tty/serial/sc16is7xx.c | 28 ++++++++++++++++++++++++++++
- 1 file changed, 28 insertions(+)
-
---- a/drivers/tty/serial/sc16is7xx.c
-+++ b/drivers/tty/serial/sc16is7xx.c
-@@ -333,6 +333,7 @@ struct sc16is7xx_port {
- struct kthread_worker kworker;
- struct task_struct *kworker_task;
- struct kthread_work irq_work;
-+ struct mutex efr_lock;
- struct sc16is7xx_one p[0];
- };
-
-@@ -504,6 +505,21 @@ static int sc16is7xx_set_baud(struct uar
- div /= 4;
- }
-
-+ /* In an amazing feat of design, the Enhanced Features Register shares
-+ * the address of the Interrupt Identification Register, and is
-+ * switched in by writing a magic value (0xbf) to the Line Control
-+ * Register. Any interrupt firing during this time will see the EFR
-+ * where it expects the IIR to be, leading to "Unexpected interrupt"
-+ * messages.
-+ *
-+ * Prevent this possibility by claiming a mutex while accessing the
-+ * EFR, and claiming the same mutex from within the interrupt handler.
-+ * This is similar to disabling the interrupt, but that doesn't work
-+ * because the bulk of the interrupt processing is run as a workqueue
-+ * job in thread context.
-+ */
-+ mutex_lock(&s->efr_lock);
-+
- lcr = sc16is7xx_port_read(port, SC16IS7XX_LCR_REG);
-
- /* Open the LCR divisors for configuration */
-@@ -519,6 +535,8 @@ static int sc16is7xx_set_baud(struct uar
- /* Put LCR back to the normal mode */
- sc16is7xx_port_write(port, SC16IS7XX_LCR_REG, lcr);
-
-+ mutex_unlock(&s->efr_lock);
-+
- sc16is7xx_port_update(port, SC16IS7XX_MCR_REG,
- SC16IS7XX_MCR_CLKSEL_BIT,
- prescaler);
-@@ -701,6 +719,8 @@ static void sc16is7xx_ist(struct kthread
- {
- struct sc16is7xx_port *s = to_sc16is7xx_port(ws, irq_work);
-
-+ mutex_lock(&s->efr_lock);
-+
- while (1) {
- bool keep_polling = false;
- int i;
-@@ -710,6 +730,8 @@ static void sc16is7xx_ist(struct kthread
- if (!keep_polling)
- break;
- }
-+
-+ mutex_unlock(&s->efr_lock);
- }
-
- static irqreturn_t sc16is7xx_irq(int irq, void *dev_id)
-@@ -904,6 +926,9 @@ static void sc16is7xx_set_termios(struct
- if (!(termios->c_cflag & CREAD))
- port->ignore_status_mask |= SC16IS7XX_LSR_BRK_ERROR_MASK;
-
-+ /* As above, claim the mutex while accessing the EFR. */
-+ mutex_lock(&s->efr_lock);
-+
- sc16is7xx_port_write(port, SC16IS7XX_LCR_REG,
- SC16IS7XX_LCR_CONF_MODE_B);
-
-@@ -925,6 +950,8 @@ static void sc16is7xx_set_termios(struct
- /* Update LCR register */
- sc16is7xx_port_write(port, SC16IS7XX_LCR_REG, lcr);
-
-+ mutex_unlock(&s->efr_lock);
-+
- /* Get baud rate generator configuration */
- baud = uart_get_baud_rate(port, termios, old,
- port->uartclk / 16 / 4 / 0xffff,
-@@ -1187,6 +1214,7 @@ static int sc16is7xx_probe(struct device
- s->regmap = regmap;
- s->devtype = devtype;
- dev_set_drvdata(dev, s);
-+ mutex_init(&s->efr_lock);
-
- kthread_init_worker(&s->kworker);
- kthread_init_work(&s->irq_work, sc16is7xx_ist);
diff --git a/target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch b/target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch
index 5ebb2a06cb..06e1ea853b 100644
--- a/target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0436-Revert-rtc-pcf8523-properly-handle-oscillator-stop-b.patch
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
--- a/drivers/rtc/rtc-pcf8523.c
+++ b/drivers/rtc/rtc-pcf8523.c
-@@ -198,8 +198,28 @@ static int pcf8523_rtc_read_time(struct
+@@ -209,8 +209,28 @@ static int pcf8523_rtc_read_time(struct
if (err < 0)
return err;
@@ -46,7 +46,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
tm->tm_sec = bcd2bin(regs[0] & 0x7f);
tm->tm_min = bcd2bin(regs[1] & 0x7f);
-@@ -235,7 +255,6 @@ static int pcf8523_rtc_set_time(struct d
+@@ -246,7 +266,6 @@ static int pcf8523_rtc_set_time(struct d
return err;
regs[0] = REG_SECONDS;
diff --git a/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch b/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
index 0a4925d6fa..cf03b00f82 100644
--- a/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
+++ b/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/net/sch_generic.h
+++ b/include/net/sch_generic.h
-@@ -368,12 +368,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -373,12 +373,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
extern struct Qdisc_ops pfifo_fast_ops;
extern struct Qdisc_ops mq_qdisc_ops;
extern struct Qdisc_ops noqueue_qdisc_ops;
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
device, it has to decide which ones to send first, which ones to
--- a/net/sched/sch_api.c
+++ b/net/sched/sch_api.c
-@@ -2029,7 +2029,7 @@ static int __init pktsched_init(void)
+@@ -2031,7 +2031,7 @@ static int __init pktsched_init(void)
return err;
}
diff --git a/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch b/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
index 484ec068d8..a2766a46b2 100644
--- a/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
@@ -267,16 +267,15 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
/*
--- a/arch/arm64/include/asm/pgtable-prot.h
+++ b/arch/arm64/include/asm/pgtable-prot.h
-@@ -48,6 +48,8 @@
- #define PROT_NORMAL_NC (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_DIRTY | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL_NC))
- #define PROT_NORMAL_WT (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_DIRTY | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL_WT))
- #define PROT_NORMAL (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_DIRTY | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL))
-+#define PROT_NORMAL_NS (PTE_TYPE_PAGE | PTE_AF | PTE_PXN | PTE_UXN | PTE_DIRTY | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL))
-+
+@@ -48,6 +48,7 @@
+ #define PROT_NORMAL_NC (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL_NC))
+ #define PROT_NORMAL_WT (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL_WT))
+ #define PROT_NORMAL (PROT_DEFAULT | PTE_PXN | PTE_UXN | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL))
++#define PROT_NORMAL_NS (PTE_TYPE_PAGE | PTE_AF | PTE_PXN | PTE_UXN | PTE_WRITE | PTE_ATTRINDX(MT_NORMAL))
#define PROT_SECT_DEVICE_nGnRE (PROT_SECT_DEFAULT | PMD_SECT_PXN | PMD_SECT_UXN | PMD_ATTRINDX(MT_DEVICE_nGnRE))
#define PROT_SECT_NORMAL (PROT_SECT_DEFAULT | PMD_SECT_PXN | PMD_SECT_UXN | PMD_ATTRINDX(MT_NORMAL))
-@@ -68,6 +70,7 @@
+@@ -68,6 +69,7 @@
#define PAGE_HYP_DEVICE __pgprot(PROT_DEVICE_nGnRE | PTE_HYP)
#define PAGE_S2 __pgprot(_PROT_DEFAULT | PTE_S2_MEMATTR(MT_S2_NORMAL) | PTE_S2_RDONLY)