aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-05-16 23:49:48 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-16 23:55:26 +0200
commita1ee0ebbd8e9927a65c5d1e0db497dd118d559a6 (patch)
tree41f914462a41313fdb7fa6480d786ebac0187397
parent84c5dbcf2a922f5713b6a24241cc09604dd9bc88 (diff)
downloadupstream-a1ee0ebbd8e9927a65c5d1e0db497dd118d559a6.tar.gz
upstream-a1ee0ebbd8e9927a65c5d1e0db497dd118d559a6.tar.bz2
upstream-a1ee0ebbd8e9927a65c5d1e0db497dd118d559a6.zip
tools/mklibs: Fix compile with GCC 11
GCC 11 defaults to C++17, but mklibs does not compile when using the C++17 standard. This patch switches back to the gnu++98 version like done in master commit 9437012b9ee4 ("tools/mklibs: update to 0.1.44 and convert to Python 3") This fixes the following compile error message: elf.hpp:52:56: error: ISO C++17 does not allow dynamic exception specifications 52 | const section &get_section(unsigned int i) const throw (std::out_of_range) { return *sections.at(i); }; Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--tools/mklibs/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
index 507c2fd394..8826840524 100644
--- a/tools/mklibs/Makefile
+++ b/tools/mklibs/Makefile
@@ -18,6 +18,7 @@ HOST_FIXUP:=autoreconf
include $(INCLUDE_DIR)/host-build.mk
HOST_CFLAGS += -I$(CURDIR)/include
+HOST_CPPFLAGS += -std=gnu++98
define Host/Install
$(INSTALL_BIN) \