aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2019-10-04 14:43:05 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 13:35:38 +0200
commit77b96c5068a38cc85c24f9d93003e46bdf42a9f4 (patch)
treec47585b9d544b24f16f5bb691a22e5d278027de7
parent24fddfa1bee67d9ed7a07621b25d24e112cdfe29 (diff)
downloadupstream-77b96c5068a38cc85c24f9d93003e46bdf42a9f4.tar.gz
upstream-77b96c5068a38cc85c24f9d93003e46bdf42a9f4.tar.bz2
upstream-77b96c5068a38cc85c24f9d93003e46bdf42a9f4.zip
ath79: add SUPPORTED_DEVICES to ubnt_nanostation-m-xw
The ar71xx images for the Ubiquiti NanoStation M (XW) devices use "nanostation-m-xw" as the board name, but the ath79 images are only compatible with the "nano-m-xw" board name, so sysupgrade complains. By adding this additional supported device, sysuspgrade smoothly upgrades from ar71xx to ath79. Tested on a NanoStation M (XW) running OpenWrt ar71xx r10250-016d1eb. Ref: https://github.com/openwrt/openwrt/pull/2418 Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> [removed duplicate DEVICE_VARIANT, removed uneeded nano-m-xw support] Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 6dda2ea6ad133705d243d3cc626779ee24bdc88d) Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index a07aa81779..97a479a14a 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -116,7 +116,7 @@ TARGET_DEVICES += ubnt_nanostation-m
define Device/ubnt_nanostation-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Nanostation M (XW)
- SUPPORTED_DEVICES += nano-m-xw
+ SUPPORTED_DEVICES += nanostation-m-xw
endef
TARGET_DEVICES += ubnt_nanostation-m-xw