aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleo chung <gewalalb@gmail.com>2019-10-16 12:22:55 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-19 14:29:44 +0200
commit3b1d71ffd885531a961ed368ebfc07a71b828a0f (patch)
tree35ee4037bcd88f7ff4931d4cb16aaf526a731536
parentddff739d15e0307767a4bf984e50bca5b5a702dd (diff)
downloadupstream-3b1d71ffd885531a961ed368ebfc07a71b828a0f.tar.gz
upstream-3b1d71ffd885531a961ed368ebfc07a71b828a0f.tar.bz2
upstream-3b1d71ffd885531a961ed368ebfc07a71b828a0f.zip
bzip2: add linker option LDFLAGS
if gcc not linker whith this LDFLAGS, "file libbz2.so.1.0.8" will recognize as pie executable ELF file ( which should be shared object). this because the file command version before 5.36 not recognize correctly. Signed-off-by: leo chung <gewalalb@gmail.com> (cherry picked from commit 56ab58fb6ce29329963619d5a4fffa9d5828176e)
-rw-r--r--package/utils/bzip2/patches/021-fix-LDFLAGS.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/utils/bzip2/patches/021-fix-LDFLAGS.patch b/package/utils/bzip2/patches/021-fix-LDFLAGS.patch
new file mode 100644
index 0000000000..7929d9a70b
--- /dev/null
+++ b/package/utils/bzip2/patches/021-fix-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/Makefile-libbz2_so
++++ b/Makefile-libbz2_so
+@@ -35,7 +35,7 @@ OBJS= blocksort.o \
+ bzlib.o
+
+ all: $(OBJS)
+- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.8 $(OBJS)
++ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 $(LDFLAGS) -o libbz2.so.1.0.8 $(OBJS)
+ $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.8
+ rm -f libbz2.so.1.0
+ ln -s libbz2.so.1.0.8 libbz2.so.1.0