aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-10-21 16:17:01 +0200
committerJohn Crispin <john@phrozen.org>2019-10-22 11:40:56 +0200
commit081d96bece97748d73e55e070e058dd735438bf0 (patch)
treee53f479df6d2afd5748982b1e8aaa60a181ad23f
parent77b96c5068a38cc85c24f9d93003e46bdf42a9f4 (diff)
downloadupstream-081d96bece97748d73e55e070e058dd735438bf0.tar.gz
upstream-081d96bece97748d73e55e070e058dd735438bf0.tar.bz2
upstream-081d96bece97748d73e55e070e058dd735438bf0.zip
ath79: fix SUPPORTED_DEVICES for ubnt_nanostation-m
The ar71xx images for the Ubiquiti NanoStation M (XM) devices use "nanostation-m" as board name, but the ath79 images are only compatible with the "nano-m" board name, so sysupgrade complains. By changing this additional supported device, sysupgrade smoothly upgrades from ar71xx to ath79. Ref: openwrt#2418 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit f473ce6f231bb9f8913be50e850c771b3463fa14)
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 97a479a14a..c51d743a35 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -109,7 +109,7 @@ TARGET_DEVICES += ubnt_rocket-m
define Device/ubnt_nanostation-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Nanostation M
- SUPPORTED_DEVICES += nano-m
+ SUPPORTED_DEVICES += nanostation-m
endef
TARGET_DEVICES += ubnt_nanostation-m