aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-01-06 16:33:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-01-06 17:47:09 +0100
commita3ffeb413bca3da273aac924f4aa0f326a66a620 (patch)
treeebbc39595f48b7b70a2dc278576dd41bfc3978f0
parentf58705b77eb20a3c39b2274168aba06233df2bc8 (diff)
downloadupstream-a3ffeb413bca3da273aac924f4aa0f326a66a620.tar.gz
upstream-a3ffeb413bca3da273aac924f4aa0f326a66a620.tar.bz2
upstream-a3ffeb413bca3da273aac924f4aa0f326a66a620.zip
ramips: Fix sysupgrade for Xiaomi mir3g
This mostly reverts the original commit e9929ebeeaef ("ramips: Fix sysupgrade for Xiaomi mir3g") and replaces it with setting the BOARD_NAME to the old value. This way the folder in the tar will be named sysupgrade-mir3g and not sysupgrade-xiaomi_mir3g and the sysupgrade in OpenWrt 18.06 can find it. Without this change sysupgrade from 18.06 to 19.07 is only possible with the -F option. I tested the following sysupgrades successfully without -F 18.06 -> 19.07 19.07 -> master master -> 19.07 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 39017a48e1..03ab9a4c37 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -269,25 +269,26 @@ define Device/xiaomi_mir3p
endef
TARGET_DEVICES += xiaomi_mir3p
-define Device/mir3g
+define Device/xiaomi_mir3g
DTS := MIR3G
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
IMAGE_SIZE := 32768k
UBINIZE_OPTS := -E 5
+ BOARD_NAME := mir3g
IMAGES += kernel1.bin rootfs0.bin
IMAGE/kernel1.bin := append-kernel
IMAGE/rootfs0.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_TITLE := Xiaomi Mi Router 3G
SUPPORTED_DEVICES += R3G
- SUPPORTED_DEVICES += xiaomi,mir3g
+ SUPPORTED_DEVICES += mir3g
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
uboot-envtools
endef
-TARGET_DEVICES += mir3g
+TARGET_DEVICES += xiaomi_mir3g
define Device/mt7621
DTS := MT7621