aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-15 15:14:27 +0200
committerJohn Crispin <john@phrozen.org>2018-05-15 15:14:27 +0200
commitf93c029395182228ccdef87d3ad7925d6bbd165d (patch)
treeed0d5a5150be70965cceae77aff6da753a3ace1f
parent7e15e21766661c29e9a9d2d9b12bdae35c775afe (diff)
downloadupstream-f93c029395182228ccdef87d3ad7925d6bbd165d.tar.gz
upstream-f93c029395182228ccdef87d3ad7925d6bbd165d.tar.bz2
upstream-f93c029395182228ccdef87d3ad7925d6bbd165d.zip
OpenWrt v18.06: set branch defaults
Signed-off-by: John Crispin <john@phrozen.org>
-rw-r--r--feeds.conf.default13
-rw-r--r--include/version.mk4
-rw-r--r--package/base-files/image-config.in2
3 files changed, 7 insertions, 12 deletions
diff --git a/feeds.conf.default b/feeds.conf.default
index da6c665624..763a26902e 100644
--- a/feeds.conf.default
+++ b/feeds.conf.default
@@ -1,9 +1,4 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git management https://github.com/openwrt-management/packages.git
-#src-git oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-18.06
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-18.06
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-18.06
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-18.06
diff --git a/include/version.mk b/include/version.mk
index ab427ecba8..a1e5608eb7 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -25,13 +25,13 @@ PKG_CONFIG_DEPENDS += \
sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),18.06-SNAPSHOT)
VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/releases/18.06-SNAPSHOT)
VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index dbbd60b152..5ee2d3e4e3 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -183,7 +183,7 @@ if VERSIONOPT
config VERSION_REPO
string
prompt "Release repository"
- default "http://downloads.lede-project.org/snapshots"
+ default "http://downloads.openwrt.org/releases/18.06-SNAPSHOT"
help
This is the repository address embedded in the image, it defaults
to the trunk snapshot repo; the url may contain the following placeholders: