aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-06-05 13:18:41 +0200
committerJo-Philipp Wich <jo@mein.io>2019-06-21 14:17:25 +0200
commit97ae9e0ccbaf3627c51588b1e940407935e1c361 (patch)
treed1a7d76bcf75b5abf434479d95adc44695070d1f
parent25fc20db8b2aa587c146bee7b3f86bdbefd127f5 (diff)
downloadupstream-97ae9e0ccbaf3627c51588b1e940407935e1c361.tar.gz
upstream-97ae9e0ccbaf3627c51588b1e940407935e1c361.tar.bz2
upstream-97ae9e0ccbaf3627c51588b1e940407935e1c361.zip
fstools: block-mount: fix restart of fstab service
Restarting service causes file-systems to be unmounted without being mounted back. When this service was obsoleted it should have been implemented in a way that all actions are ignored. Up to this commit default handler was called when restart was requested. This default handler just simply calls stop and start. That means that stop called unmount but start just printed that this service is obsoleted. This instead implements restart that just prints same message like start does. It just calls start in reality. This makes restart unavailable for call. Signed-off-by: Karel Kočí <karel.koci@nic.cz> (cherry picked from commit 3ead9e7b743b1fbd3b07f5a72a16999abbec9347)
-rw-r--r--package/system/fstools/Makefile2
-rw-r--r--package/system/fstools/files/fstab.init4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 3c318df511..3aa250f7d4 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fstools
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
diff --git a/package/system/fstools/files/fstab.init b/package/system/fstools/files/fstab.init
index 5faa8ecbb9..afed78ebfc 100644
--- a/package/system/fstools/files/fstab.init
+++ b/package/system/fstools/files/fstab.init
@@ -11,6 +11,10 @@ start() {
echo "this file has been obsoleted. please call \"/sbin/block mount\" directly"
}
+restart() {
+ start
+}
+
stop() {
/sbin/block umount
}