aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-05-17 14:34:09 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-05-21 09:48:48 +0200
commit85294fc5e7012130d3b23a5b23f44a12affa715f (patch)
treebdb312ddd5cf693694bf1b161b33e2bbdd29c642
parent152755c9a26f9926aad0c032ea026d41953a9e51 (diff)
downloadupstream-85294fc5e7012130d3b23a5b23f44a12affa715f.tar.gz
upstream-85294fc5e7012130d3b23a5b23f44a12affa715f.tar.bz2
upstream-85294fc5e7012130d3b23a5b23f44a12affa715f.zip
kernel: bump 4.9 to 4.9.177
Refreshed all patches. Compile-tested on: ar71xx Runtime-tested on: ar71xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch2
-rw-r--r--target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch4
-rw-r--r--target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch2
4 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 03dbc45f32..1a5d781af1 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,10 +2,10 @@
LINUX_RELEASE?=1
-LINUX_VERSION-4.9 = .176
+LINUX_VERSION-4.9 = .177
LINUX_VERSION-4.14 = .119
-LINUX_KERNEL_HASH-4.9.176 = 2a94d008c0737f01d4b78f669a3c40e334cacebe4d62eb25252171cee205b178
+LINUX_KERNEL_HASH-4.9.177 = c73b1e3ebcc35b653f7b673ca151fc67b814bdb27269799fa7cda251827887ee
LINUX_KERNEL_HASH-4.14.119 = 5615b713389d74044eaa57032dab674228116b63ed358086c33bd929d7ad3b7c
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch b/target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch
index 3091ab69b6..139b09c1b0 100644
--- a/target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch
+++ b/target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/setup.c
+++ b/arch/mips/ath79/setup.c
-@@ -283,6 +283,8 @@ void __init plat_time_init(void)
+@@ -277,6 +277,8 @@ void __init plat_time_init(void)
mips_hpt_frequency = cpu_clk_rate / 2;
}
diff --git a/target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch b/target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch
index 89dd32a7c1..ba855e1500 100644
--- a/target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch
+++ b/target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch
@@ -10,7 +10,7 @@
--- a/arch/mips/ath79/setup.c
+++ b/arch/mips/ath79/setup.c
-@@ -196,16 +196,20 @@ unsigned int get_c0_compare_int(void)
+@@ -190,16 +190,20 @@ unsigned int get_c0_compare_int(void)
void __init plat_mem_setup(void)
{
@@ -31,7 +31,7 @@
if (mips_machtype != ATH79_MACH_GENERIC_OF) {
ath79_reset_base = ioremap_nocache(AR71XX_RESET_BASE,
-@@ -301,17 +305,21 @@ static int __init ath79_setup(void)
+@@ -295,17 +299,21 @@ static int __init ath79_setup(void)
arch_initcall(ath79_setup);
diff --git a/target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch b/target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch
index 6c2b21d157..0eaf1ed70c 100644
--- a/target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch
+++ b/target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch
@@ -1,6 +1,6 @@
--- a/arch/x86/kernel/reboot.c
+++ b/arch/x86/kernel/reboot.c
-@@ -449,6 +449,16 @@ static struct dmi_system_id __initdata r
+@@ -470,6 +470,16 @@ static struct dmi_system_id __initdata r
},
},