aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-17 21:32:50 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-17 22:03:25 +0200
commit3239f5613696ff3bdeeafc0eceb00550e2005ced (patch)
tree5604d4731a1de165af23808f7f7af9a667e67fa5
parentb5ce5217e2ee26a24cdb65313217fdec6e7e82e1 (diff)
downloadupstream-3239f5613696ff3bdeeafc0eceb00550e2005ced.tar.gz
upstream-3239f5613696ff3bdeeafc0eceb00550e2005ced.tar.bz2
upstream-3239f5613696ff3bdeeafc0eceb00550e2005ced.zip
uboot-fritz4040: Add host flags for host compiler
This adds the host staging directory to the include path to make it use the zlib.h files from the staging include directory and also link against the zlib version from the staging directory. This fixes a compile problem when the zlib header were not installed on the build host. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/boot/uboot-fritz4040/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index 659bd0d084..4f920485c4 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -35,8 +35,8 @@ export DTC
define Build/Configure
$(Build/Configure/U-Boot)
- $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
- $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
+ $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
+ $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
ln -sf $(STAGING_DIR_HOST)/bin/lzma $(PKG_BUILD_DIR)/fritz
ln -sf compiler-gcc5.h $(PKG_BUILD_DIR)/include/linux/compiler-gcc7.h
endef