aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-06-03 13:41:17 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-06-03 17:01:20 +0200
commit1867f108075a875c3334d827beff74bc6c24f2f6 (patch)
treef62a741c27fae576c172c64774871e515d654cba
parent7fe1b4a4b2c93de98acc7e613273883ecd7b14bf (diff)
downloadupstream-1867f108075a875c3334d827beff74bc6c24f2f6.tar.gz
upstream-1867f108075a875c3334d827beff74bc6c24f2f6.tar.bz2
upstream-1867f108075a875c3334d827beff74bc6c24f2f6.zip
kernel: bump 4.14 to 4.14.123
Refreshed all patches. Compile-tested on: cns3xxx, imx6 Runtime-tested on: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/cns3xxx/patches-4.14/075-spi_support.patch2
-rw-r--r--target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 23c3976b3b..0f1dfcec27 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-4.9 = .180
-LINUX_VERSION-4.14 = .122
+LINUX_VERSION-4.14 = .123
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
-LINUX_KERNEL_HASH-4.14.122 = c8a3f40ef877e18b3d2890e0954f2d81b6d012a7321836ca4e5b036ef93f68f5
+LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/cns3xxx/patches-4.14/075-spi_support.patch b/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
index e38dbdb75e..401ec876e9 100644
--- a/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
+++ b/target/linux/cns3xxx/patches-4.14/075-spi_support.patch
@@ -39,7 +39,7 @@
/**
--- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c
-@@ -1027,6 +1027,9 @@ static int spi_transfer_one_message(stru
+@@ -1029,6 +1029,9 @@ static int spi_transfer_one_message(stru
list_for_each_entry(xfer, &msg->transfers, transfer_list) {
trace_spi_transfer_start(msg, xfer);
diff --git a/target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch b/target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch
index 19400af189..bf46428854 100644
--- a/target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch
+++ b/target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif /* _KOBJECT_H_ */
--- a/lib/kobject_uevent.c
+++ b/lib/kobject_uevent.c
-@@ -599,6 +599,43 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -602,6 +602,43 @@ int add_uevent_var(struct kobj_uevent_en
EXPORT_SYMBOL_GPL(add_uevent_var);
#if defined(CONFIG_NET)