aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-16 11:04:27 +0000
committerJohn Crispin <john@openwrt.org>2012-12-16 11:04:27 +0000
commite9c0b958295bb055fefc03b1e356051f99218f28 (patch)
tree2884dc302a0f87ff335a0d5a31a8b9a20384f61b
parent7bcb6b54791ca68ed3433ea0db1bba270d7d0f25 (diff)
downloadupstream-e9c0b958295bb055fefc03b1e356051f99218f28.tar.gz
upstream-e9c0b958295bb055fefc03b1e356051f99218f28.tar.bz2
upstream-e9c0b958295bb055fefc03b1e356051f99218f28.zip
fixes uapi helper define
SVN-Revision: 34715
-rw-r--r--include/kernel.mk5
-rw-r--r--package/network/services/ppp/Makefile2
2 files changed, 4 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index eabf9484fa..6185237765 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -35,8 +35,9 @@ else
endif
KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
- LINUX_UAPI_DIR=$(firstword $(wildcard $(LINUX_DIR)/include/uapi $(LINUX_DIR)/include))
-
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+ LINUX_UAPI_DIR=uapi/
+ endif
LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 49c6a40a4c..71c598196b 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -158,7 +158,7 @@ $(call Build/Configure/Default,, \
mkdir -p $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux
cp \
$(LINUX_DIR)/include/linux/compiler.h \
- $(LINUX_UAPI_DIR)/linux/atm*.h \
+ $(LINUX_DIR)/include/$(LINUX_UAPI_DIR)linux/atm*.h \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef