aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGünther Kelleter <guenther.kelleter@devolo.de>2018-10-08 15:30:00 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-30 13:21:02 +0100
commitcddd7b4c778a68194319630274b1849e8f788a89 (patch)
treede7afff4548dfa9534d796b43415793eac4ba8db
parente6162b212796838660719be072378818997bb9f3 (diff)
downloadupstream-cddd7b4c778a68194319630274b1849e8f788a89.tar.gz
upstream-cddd7b4c778a68194319630274b1849e8f788a89.tar.bz2
upstream-cddd7b4c778a68194319630274b1849e8f788a89.zip
base-files: config_get: prevent filename globbing
When config_get is called as "config_get section option" the option is unexpectedly globbed by the shell which differs from the way options are read to a variable with "config_get variable section option". Add another layer of double quotes to fix it. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> (backported from commit c3389ab135400fba0cb710d9c6c63df2f563d9d9)
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/functions.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 9134f118e0..904f4af073 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=194.1
+PKG_RELEASE:=194.2
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions.sh b/package/base-files/files/lib/functions.sh
index 50a7b40869..edce75e8ff 100755
--- a/package/base-files/files/lib/functions.sh
+++ b/package/base-files/files/lib/functions.sh
@@ -92,7 +92,7 @@ config_unset() {
# config_get <section> <option>
config_get() {
case "$3" in
- "") eval echo "\${CONFIG_${1}_${2}:-\${4}}";;
+ "") eval echo "\"\${CONFIG_${1}_${2}:-\${4}}\"";;
*) eval export ${NO_EXPORT:+-n} -- "${1}=\${CONFIG_${2}_${3}:-\${4}}";;
esac
}