aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Yang <mmyangfl@gmail.com>2018-08-11 15:51:02 +0800
committerJo-Philipp Wich <jo@mein.io>2018-12-18 11:28:14 +0100
commit9a01ff5c0349c01d2182d9b4f15fe7ba8b156329 (patch)
treebba089d4bd7c4623505b5febeaf23bb55ba59c64
parent991e43c894d0e6e74a1010ff4f327e25ca69fd9a (diff)
downloadupstream-9a01ff5c0349c01d2182d9b4f15fe7ba8b156329.tar.gz
upstream-9a01ff5c0349c01d2182d9b4f15fe7ba8b156329.tar.bz2
upstream-9a01ff5c0349c01d2182d9b4f15fe7ba8b156329.zip
dante: disable sched_getscheduler() - not implemented in musl
musl doesn't come with an valid implementation of `sched_getscheduler()`; it simply returns -ENOSYS for it. Without this option (and compile dante with `sched_getscheduler()` enabled), you will get error: serverinit(): sched_getscheduler(2): failed to retrieve current cpuscheduling policy: Function not implemented and dante won't start at all. Ref: http://lists.alpinelinux.org/alpine-devel/3932.html Ref: http://lists.alpinelinux.org/alpine-devel/3936.html Signed-off-by: David Yang <mmyangfl@gmail.com> [slightly reword commit message] Signed-off-by: Jo-Philipp Wich <jo@mein.io> (backported from aaf46a8fe23eca959164c1681ab3a37c6e746b05)
-rw-r--r--package/network/utils/dante/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/network/utils/dante/Makefile b/package/network/utils/dante/Makefile
index 6f821122b2..1c57b120f8 100644
--- a/package/network/utils/dante/Makefile
+++ b/package/network/utils/dante/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dante
PKG_VERSION:=1.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.inet.no/dante/files/
@@ -29,7 +29,8 @@ CONFIGURE_ARGS += \
--disable-libwrap
CONFIGURE_VARS += \
- ac_cv_search_pam_start=""
+ ac_cv_search_pam_start="" \
+ ac_cv_func_sched_setscheduler=no
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
@@ -49,7 +50,7 @@ Dante is a circuit-level firewall/proxy that can be used to provide convenient
and secure network connectivity, requiring only that the server Dante runs on
has external network connectivity. Dante is used daily by Fortune 100 companies
and large international organizations, either as a standard SOCKS server or as
-a "reverse proxy".
+a "reverse proxy".
endef
define Package/libsocks