aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-09-20 14:35:27 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-09-21 13:23:59 +0200
commit0d8d63c038a3f52ee3f537f454c71becd22e6b55 (patch)
tree76587eeae9406e5f8c1e76dbbf21039f687b4cfe
parentf506de2cdaf92a5716298cf9d63cc686a1097a29 (diff)
downloadupstream-0d8d63c038a3f52ee3f537f454c71becd22e6b55.tar.gz
upstream-0d8d63c038a3f52ee3f537f454c71becd22e6b55.tar.bz2
upstream-0d8d63c038a3f52ee3f537f454c71becd22e6b55.zip
kernel: bump 4.9 to 4.9.128
Refreshed all patches. Compile-tested on: ar71xx Runtime-tested on: ar71xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 4c35b124a4..c6124d2809 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,11 +2,11 @@
LINUX_RELEASE?=1
-LINUX_VERSION-4.9 = .127
LINUX_VERSION-4.14 = .70
+LINUX_VERSION-4.9 = .128
-LINUX_KERNEL_HASH-4.9.127 = 9477aeaded97589a40d7cbbfeebfa7a8f863130c0729a8dc5cdbcf48eb6fdd0f
LINUX_KERNEL_HASH-4.14.70 = c5dfd832477f8856b5b094ab62cc8c8491d04b76b2ec5ebb0126e554891ee32c
+LINUX_KERNEL_HASH-4.9.128 = bdb76f48491a6aadc89c0f0f7fdc240d77cee54da5aac59da0b5d98e226b6f12
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch b/target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch
index 9725779c3e..b424da8d32 100644
--- a/target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch
+++ b/target/linux/brcm47xx/patches-4.9/159-cpu_fixes.patch
@@ -396,7 +396,7 @@
if (dc_lsize == 0)
r4k_blast_dcache = (void *)cache_noop;
else if (dc_lsize == 16)
-@@ -955,6 +967,8 @@ static void local_r4k_flush_cache_sigtra
+@@ -957,6 +969,8 @@ static void local_r4k_flush_cache_sigtra
}
R4600_HIT_CACHEOP_WAR_IMPL;
@@ -405,7 +405,7 @@
if (!cpu_has_ic_fills_f_dc) {
if (dc_lsize)
vaddr ? flush_dcache_line(addr & ~(dc_lsize - 1))
-@@ -1843,6 +1857,17 @@ static void coherency_setup(void)
+@@ -1845,6 +1859,17 @@ static void coherency_setup(void)
* silly idea of putting something else there ...
*/
switch (current_cpu_type()) {
@@ -423,7 +423,7 @@
case CPU_R4000PC:
case CPU_R4000SC:
case CPU_R4000MC:
-@@ -1889,6 +1914,15 @@ void r4k_cache_init(void)
+@@ -1891,6 +1916,15 @@ void r4k_cache_init(void)
extern void build_copy_page(void);
struct cpuinfo_mips *c = &current_cpu_data;
@@ -439,7 +439,7 @@
probe_pcache();
probe_vcache();
setup_scache();
-@@ -1966,7 +2000,15 @@ void r4k_cache_init(void)
+@@ -1968,7 +2002,15 @@ void r4k_cache_init(void)
*/
local_r4k___flush_cache_all(NULL);