aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2019-01-02 07:13:19 +0100
committerRafał Miłecki <rafal@milecki.pl>2019-01-10 07:16:42 +0100
commit069fda746e3c407a2f61ee9368f264700bea20cd (patch)
tree56be2cccf6c6b07a400be673fc7dc839dde2b0e9
parent3b4e779e93dea90f910e7974769c5208e4c0a0ad (diff)
downloadupstream-069fda746e3c407a2f61ee9368f264700bea20cd.tar.gz
upstream-069fda746e3c407a2f61ee9368f264700bea20cd.tar.bz2
upstream-069fda746e3c407a2f61ee9368f264700bea20cd.zip
fstools: update to the latest master branch
This is a big block(d) cleanup with new feature of generating "mount" hotplug.d events. It's an important update for those who were using mountd in the pre-18.06 releases. Due to the mountd being replaced with blockd a support for "mountd" hotplug.d events has been lost. It broke all kind of shell scripts that were e.g. managing services depending on an external USB drive availability. This basically (re-)adds support for calling /etc/hotplug.d/mount/ scripts with ACTION ("add" or "remove") and DEVICE set. af93f4b block(d): improve hotplug.d "mount" events for the autofs 3bb3352 blockd: unmount device explicitly when it disappears 28753b3 block: remove target directory after unmounting c8c7ca5 block: cleanup handling "start" action of the "autofs" command f1bb762 block: make blockd_notify() return an int instead of void 71c2bde block: generate hotplug.d mount events 30f5096 block: validate amount of arguments for the "autofs" command dc6a462 blockd: don't reparse blob msg in the vlist callbacks f6a9686 blockd: don't unmount device when removing it from the list 1913fea block: don't duplicate unmounting code in the mount_action() 6b445fa block: make umount_device() function more generic a778468 block: don't duplicate mounting code in the mount_device() 5dc631d block: simplify code picking mount target directory 2971779 block: move blockd_notify() call out of the conditional blocks b86bd6e block: fix formatting & indent in the mount_device() e12c0d6 fstools: use EXIT_FAILURE when indicating error on exit 091aa3d fstools: guard usage of WEXITSTATUS Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 5c4277ec376541b10f1acbea734aa29900eb5722)
-rw-r--r--package/system/fstools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 3f8fbd99f4..58be215f8f 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
-PKG_SOURCE_DATE:=2018-09-29
-PKG_SOURCE_VERSION:=29e53af0b91954ca6a13bdd1f0e67c939ccb8e6d
-PKG_MIRROR_HASH:=e90c60362dc3f304c9748b57a3e602f37fd758bf8134fbc3fbbda4300d4f46c7
+PKG_SOURCE_DATE:=2018-12-28
+PKG_SOURCE_VERSION:=af93f4b8dc32cf1320dfe8f4b93bb3a12606fc33
+PKG_MIRROR_HASH:=a2d8c2500fe75014ef16c039d8cdb276c1d5c066f8bce6550a3ecf46a9a411a9
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0