diff options
author | Florian Fainelli <f.fainelli@gmail.com> | 2017-01-14 20:04:38 -0800 |
---|---|---|
committer | Jo-Philipp Wich <jo@mein.io> | 2017-12-13 14:15:08 +0100 |
commit | 3387158e45b1c0e329617d265392974b121230e7 (patch) | |
tree | b90926bc51594d64be82f9271fa76cf46af5bde8 | |
parent | 2428b6d6b6dafd88bd184e6bd1eea6ba0a4305c0 (diff) | |
download | upstream-3387158e45b1c0e329617d265392974b121230e7.tar.gz upstream-3387158e45b1c0e329617d265392974b121230e7.tar.bz2 upstream-3387158e45b1c0e329617d265392974b121230e7.zip |
build: Suffix build directory with _$(LIBC) for external toolchains
For external toolchain, we also know the type of C library used, and the
toolchain triplet may not always be reflective of that, therefore make
$(TARGET_DIR_NAME) suffixed with _$(LIBC).
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
(cherry picked from commit 57657a72376000b5843367e627098f09fe9c3647)
-rw-r--r-- | rules.mk | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -124,7 +124,8 @@ else GNU_TARGET_NAME=$(shell gcc -dumpmachine) endif REAL_GNU_TARGET_NAME=$(GNU_TARGET_NAME) - TARGET_DIR_NAME:=target-$(GNU_TARGET_NAME)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX)) + LIBC:=$(call qstrip,$(CONFIG_LIBC)) + TARGET_DIR_NAME:=target-$(GNU_TARGET_NAME)_$(LIBC)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX)) TOOLCHAIN_DIR_NAME:=toolchain-$(GNU_TARGET_NAME) endif |