aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-05-25 14:41:34 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-25 23:21:36 +0800
commit2f92622ce8e1bf3a27ecd0aa7e71a5b2aee39f12 (patch)
tree255eb5b3919d01c964bdf440ccaf570dac0fc360
parent9c2bd3d631c514eb8bb8c1940103d7e43d50f0b9 (diff)
downloadupstream-2f92622ce8e1bf3a27ecd0aa7e71a5b2aee39f12.tar.gz
upstream-2f92622ce8e1bf3a27ecd0aa7e71a5b2aee39f12.tar.bz2
upstream-2f92622ce8e1bf3a27ecd0aa7e71a5b2aee39f12.zip
kernel: fix autoloading arch-specific modules
Fixes FS#745 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--package/kernel/linux/modules/crypto.mk14
-rw-r--r--package/kernel/linux/modules/sound.mk2
-rw-r--r--package/kernel/linux/modules/video.mk2
3 files changed, 9 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 67526024e5..a3092562c5 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -436,7 +436,7 @@ endef
define KernelPackage/crypto-md5/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-md5.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-md5)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-md5)
endef
$(eval $(call KernelPackage,crypto-md5))
@@ -468,12 +468,12 @@ endef
define KernelPackage/crypto-sha1/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha1.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha1)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha1)
endef
define KernelPackage/crypto-sha1/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha1-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha1-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha1-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha1))
@@ -493,12 +493,12 @@ endef
define KernelPackage/crypto-sha256/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha256.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha256)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha256)
endef
define KernelPackage/crypto-sha256/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha256-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha256-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha256-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha256))
@@ -518,12 +518,12 @@ endef
define KernelPackage/crypto-sha512/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha512.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha512)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha512)
endef
define KernelPackage/crypto-sha512/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha512-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha512-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha512-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha512))
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index de5d8fc2c6..75aa3d3fc4 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -67,7 +67,7 @@ define KernelPackage/sound-core/uml
FILES:= \
$(LINUX_DIR)/sound/soundcore.ko \
$(LINUX_DIR)/arch/um/drivers/hostaudio.ko
- AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
+ AUTOLOAD+=$(call AutoLoad,30,soundcore hostaudio)
endef
define KernelPackage/sound-core/description
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 7967fdab1c..13ff14cbb6 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -72,7 +72,7 @@ endef
define KernelPackage/fb/x86
FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
- AUTOLOAD:=$(call AutoLoad,06,fbdev fb)
+ AUTOLOAD+=$(call AutoLoad,06,fbdev fb)
endef
$(eval $(call KernelPackage,fb))