aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-10 20:48:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-10 20:48:31 +0000
commitfc3c1317b77c7ae816f8e66ef0f1987ac4eb45c8 (patch)
treefb116354e3e853f1069e0290f02600c2805d031c
parent513257a2fb69b270660b3d54acc4ac09808e50ed (diff)
downloadupstream-fc3c1317b77c7ae816f8e66ef0f1987ac4eb45c8.tar.gz
upstream-fc3c1317b77c7ae816f8e66ef0f1987ac4eb45c8.tar.bz2
upstream-fc3c1317b77c7ae816f8e66ef0f1987ac4eb45c8.zip
lua: enable parallel builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33716 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/lua/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index c5df4d5426..fca7747cd5 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
http://mirrors.dotsrc.org/lua/ \
http://www.tecgraf.puc-rio.br/lua/ftp/
PKG_MD5SUM:=2e115fe26e435e33b0d5c022e4490567
+PKG_BUILD_PARALLEL:=1
HOST_PATCH_DIR := ./patches-host
@@ -96,7 +97,7 @@ ifneq ($(CONFIG_USE_EGLIBC),)
endif
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \
AR="$(TARGET_CROSS)ar rcu" \
RANLIB="$(TARGET_CROSS)ranlib" \