diff options
author | Florian Fainelli <florian@openwrt.org> | 2013-04-05 12:36:19 +0000 |
---|---|---|
committer | Florian Fainelli <florian@openwrt.org> | 2013-04-05 12:36:19 +0000 |
commit | d32ac499b87e188755b5e3245e1d0bc181e6e6ed (patch) | |
tree | faa476e0739ea06fe71e44e6b1150ca1bfc5fa58 | |
parent | 070c70f3e05d660b019da593c483c2930e5cb03e (diff) | |
download | upstream-d32ac499b87e188755b5e3245e1d0bc181e6e6ed.tar.gz upstream-d32ac499b87e188755b5e3245e1d0bc181e6e6ed.tar.bz2 upstream-d32ac499b87e188755b5e3245e1d0bc181e6e6ed.zip |
buildroot: factor knowledge of a 64bits architecture
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36204 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | rules.mk | 2 | ||||
-rw-r--r-- | target/Config.in | 7 | ||||
-rw-r--r-- | toolchain/gcc/final/Makefile | 2 |
3 files changed, 9 insertions, 2 deletions
@@ -132,7 +132,7 @@ endif LIBRPC=-lrpc LIBRPC_DEPENDS=+librpc -ifneq ($(findstring $(ARCH) , mips64 x86_64 ),) +ifeq ($(CONFIG_ARCH_64BIT),y) LIB_SUFFIX:=64 endif diff --git a/target/Config.in b/target/Config.in index 79a91b1afb..8ff89ff8a9 100644 --- a/target/Config.in +++ b/target/Config.in @@ -70,6 +70,9 @@ config HAS_MIPS16 depends (mips || mipsel || mips64 || mips64el) bool +config ARCH_64BIT + bool + # Architecture selection config arm @@ -104,9 +107,11 @@ config mipsel config mips64 select BIG_ENDIAN + select ARCH_64BIT bool config mips64el + select ARCH_64BIT bool config powerpc @@ -115,6 +120,7 @@ config powerpc config powerpc64 select BIG_ENDIAN + select ARCH_64BIT bool config sh3 @@ -136,6 +142,7 @@ config sparc bool config x86_64 + select ARCH_64BIT bool config ARCH diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile index a667266a09..e8c32f629d 100644 --- a/toolchain/gcc/final/Makefile +++ b/toolchain/gcc/final/Makefile @@ -35,7 +35,7 @@ define CleanupToolchain ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib - $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64) + $(if $(CONFIG_ARCH_64BIT),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64) endef define Host/Configure |