diff options
author | Felix Fietkau <nbd@openwrt.org> | 2014-10-22 08:57:40 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2014-10-22 08:57:40 +0000 |
commit | a7a8f77c08d5cb7ed1be71e0eb85a2f3d137aca9 (patch) | |
tree | d6be65d52fcc4e83ab4da464675f15287dbd4565 | |
parent | 0bd0ddadc5b29da9fa4328a913c9728950e53d3d (diff) | |
download | upstream-a7a8f77c08d5cb7ed1be71e0eb85a2f3d137aca9.tar.gz upstream-a7a8f77c08d5cb7ed1be71e0eb85a2f3d137aca9.tar.bz2 upstream-a7a8f77c08d5cb7ed1be71e0eb85a2f3d137aca9.zip |
build: use ONESHELL to speed up scanning and the toplevel makefile
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43021 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Makefile | 1 | ||||
-rw-r--r-- | include/scan.mk | 1 | ||||
-rw-r--r-- | include/target.mk | 1 |
3 files changed, 3 insertions, 0 deletions
@@ -15,6 +15,7 @@ empty:= space:= $(empty) $(empty) $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces)) +.ONESHELL: world: include $(TOPDIR)/include/host.mk diff --git a/include/scan.mk b/include/scan.mk index 0998333439..2f2753f2a0 100644 --- a/include/scan.mk +++ b/include/scan.mk @@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP) FORCE: .PHONY: FORCE .NOTPARALLEL: +.ONESHELL: diff --git a/include/target.mk b/include/target.mk index 3401f849a5..657109e75d 100644 --- a/include/target.mk +++ b/include/target.mk @@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:= ifneq ($(DUMP),) all: dumpinfo + .ONESHELL: endif target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1)))) |