aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-12-26 13:33:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-12-26 13:33:22 +0000
commit826c6d187c64b0e1163ade4cdc246a90cac42263 (patch)
tree870e3278b6ead05b46c44d9bce5a2ab4d1db0cbd
parent27f57bec0e0a677f7bffd032ad104e65f7529020 (diff)
downloadupstream-826c6d187c64b0e1163ade4cdc246a90cac42263.tar.gz
upstream-826c6d187c64b0e1163ade4cdc246a90cac42263.tar.bz2
upstream-826c6d187c64b0e1163ade4cdc246a90cac42263.zip
The ubinized filesystems should be used for generating the
final images, so store them in KDIR instead. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43778 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/image.mk2
-rw-r--r--target/linux/mvebu/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 12322bdb8d..f9b8998ed4 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -154,7 +154,7 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
define Image/Build/UbinizeImage
sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
"$(KDIR)/root.$(3)" \
- "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
+ "$(KDIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
$(4)
endef
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 9d3b6353a6..c2dcd8cd06 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -46,7 +46,7 @@ define Image/Build/squashfs
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/UbinizeImage,$(dtb),,squashfs,$(UBI_OPTS));)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
- dd if=$(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
bs=2048 conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-factory.img
endef