aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-09 13:27:39 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-09 13:27:39 +0000
commitecf9b8d37d6fb00046bb720c36d516b74cd5068b (patch)
tree0ed6219d865364a0ca32f0a459325dff50a7a845
parentb59b28a91d71b9a176de2859dc7a6cd6b7879b57 (diff)
downloadupstream-ecf9b8d37d6fb00046bb720c36d516b74cd5068b.tar.gz
upstream-ecf9b8d37d6fb00046bb720c36d516b74cd5068b.tar.bz2
upstream-ecf9b8d37d6fb00046bb720c36d516b74cd5068b.zip
[kernel] netfilter: remove CHAOS, TARPIT and DELUDE references
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14461 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/netfilter.mk4
-rw-r--r--package/iptables/Makefile3
-rw-r--r--package/kernel/modules/netfilter.mk3
3 files changed, 0 insertions, 10 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 6968feffd3..f474b6a398 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -84,13 +84,9 @@ $(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_OWNER, $(P_V4)ipt_owner))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PHYSDEV, $(P_XT)xt_physdev))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_PKTTYPE, $(P_V4)ipt_pkttype))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PKTTYPE, $(P_XT)xt_pkttype))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_PORTSCAN, $(P_XT)xt_portscan))
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_MATCH_QUOTA, $(P_V4)ipt_quota))
$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_MATCH_QUOTA, $(P_XT)xt_quota))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_TARPIT, $(P_XT)xt_TARPIT))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_DELUDE, $(P_XT)xt_DELUDE))
-$(eval $(call nf_add,IPT_EXTRA,CONFIG_NETFILTER_XT_TARGET_CHAOS, $(P_XT)xt_CHAOS))
#$(eval $(call nf_add,IPT_EXTRA,CONFIG_IP_NF_TARGET_ROUTE, $(P_V4)ipt_ROUTE))
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 58b4d722d5..1074f582cc 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -211,9 +211,6 @@ define Package/iptables-mod-extra/description
- libipt_recent
- iptable_raw
- libipt_NOTRACK
- - libipt_TARPIT
- - libipt_DELUDE
- - libipt_CHAOS
endef
define Package/iptables-mod-ipset
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index c17c8a8def..3cb00d6855 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -347,9 +347,6 @@ define KernelPackage/ipt-extra/description
- ipt_recent
- iptable_raw
- xt_NOTRACK
- - xt_TARPIT
- - xt_DELUDE
- - xt_CHAOS
endef
$(eval $(call KernelPackage,ipt-extra))