aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-21 16:26:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-21 16:26:27 +0000
commite938e513ebb14df81346ab7051c0efb99ce291da (patch)
treed3e1a7570301862f7d1b86a6106602fae6c9645c
parent6c320f23a582ce667e622479d3ea63adbd8d0ea5 (diff)
downloadupstream-e938e513ebb14df81346ab7051c0efb99ce291da.tar.gz
upstream-e938e513ebb14df81346ab7051c0efb99ce291da.tar.bz2
upstream-e938e513ebb14df81346ab7051c0efb99ce291da.zip
move the EABI config override to the generic kernel config overrides, as it's arch specific, not target specific - fixes spurious kernel rebuild issues with EABI
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14594 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-defaults.mk2
-rw-r--r--target/linux/ixp4xx/Makefile6
2 files changed, 2 insertions, 6 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index f0639e39fe..de07b91189 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -91,6 +91,8 @@ define Kernel/Configure/Default
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config.target
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config.target)
$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
$(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
$(call Kernel/SetInitramfs)
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index cfe76d8bce..1499075f1d 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -16,12 +16,6 @@ LINUX_VERSION:=2.6.28.6
include $(INCLUDE_DIR)/target.mk
-define Kernel/Configure
- $(call Kernel/Configure/Default)
- $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
- $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
DEFAULT_PACKAGES += ixp4xx-microcode fconfig
$(eval $(call BuildTarget))