aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
commit99abe56d0835e449f13a20f2198c328a88c450f0 (patch)
tree68a47a005751b61cff44d3a7c5886a7c3560c304
parentd7dada693ad0c6a007096991000b5da38c773027 (diff)
downloadupstream-99abe56d0835e449f13a20f2198c328a88c450f0.tar.gz
upstream-99abe56d0835e449f13a20f2198c328a88c450f0.tar.bz2
upstream-99abe56d0835e449f13a20f2198c328a88c450f0.zip
deptest: Install of host tools has to be forced for every test, because the host staging dir is cleaned prior a test.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23825 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/host-build.mk4
-rwxr-xr-xscripts/deptest.sh1
2 files changed, 3 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1b7f354066..6f742d28a1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -153,12 +153,12 @@ ifndef DUMP
$(call Host/Compile)
touch $$@
- $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+ $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install)
mkdir -p $$(shell dirname $$@)
touch $$@
else
- $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Compile)
$(call Host/Install)
touch $$@
diff --git a/scripts/deptest.sh b/scripts/deptest.sh
index 730ca5bd35..a0c3017c7d 100755
--- a/scripts/deptest.sh
+++ b/scripts/deptest.sh
@@ -74,6 +74,7 @@ test_package() # $1=pkgname
BUILD_DIR_HOST="$BUILD_DIR_HOST" \
STAGING_DIR="$STAGING_DIR" \
STAGING_DIR_HOST="$STAGING_DIR_HOST" \
+ FORCE_HOST_INSTALL=1 \
V=99 >"$LOG_DIR/$(basename $pkg).log" 2>&1
if [ $? -eq 0 ]; then
touch "$STAMP_SUCCESS"