aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-02-15 20:03:18 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-02-15 20:03:18 +0000
commit76f39fa3a7f168771244b88056eb90b26a18d26a (patch)
tree240220016edd49c197701ca28e01ac8ce70a8bc4
parentedc6ce204847182dcf2fb2122a99a0de4f5dbc4f (diff)
downloadupstream-76f39fa3a7f168771244b88056eb90b26a18d26a.tar.gz
upstream-76f39fa3a7f168771244b88056eb90b26a18d26a.tar.bz2
upstream-76f39fa3a7f168771244b88056eb90b26a18d26a.zip
Add audio feature flag.
There are targets which neither have usb host nor pci support but do have audio capabilities. Those targets should expliclitly specifiy that they support audio through the new feature flag. The audio feature flag is also implicitly selected by the usb and pci feature flags. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19643 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/sound.mk2
-rwxr-xr-xscripts/metadata.pl1
-rw-r--r--target/Config.in5
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/xburst/Makefile4
5 files changed, 10 insertions, 4 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 9350dbf344..53f65e5ad1 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)
TITLE:=Sound support
- DEPENDS:=@PCI_SUPPORT||USB_SUPPORT||TARGET_uml
+ DEPENDS:=@AUDIO_SUPPORT
KCONFIG:= \
CONFIG_SOUND \
CONFIG_SND \
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 9260a1b24b..c963964ba3 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -152,6 +152,7 @@ sub target_config_features(@) {
while ($_ = shift @_) {
/broken/ and $ret .= "\tdepends BROKEN\n";
+ /audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
/display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
/gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
/pci/ and $ret .= "\tselect PCI_SUPPORT\n";
diff --git a/target/Config.in b/target/Config.in
index f5aa043053..f881245c62 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -11,6 +11,9 @@ config LINUX_2_6
config HAS_FPU
bool
+config AUDIO_SUPPORT
+ bool
+
config DISPLAY_SUPPORT
bool
@@ -18,6 +21,7 @@ config GPIO_SUPPORT
bool
config PCI_SUPPORT
+ select AUDIO_SUPPORT
bool
config PCIE_SUPPORT
@@ -27,6 +31,7 @@ config PCMCIA_SUPPORT
bool
config USB_SUPPORT
+ select AUDIO_SUPPORT
bool
config BIG_ENDIAN
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 5f3181fce2..f2d9ce4525 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -20,7 +20,7 @@ ARCH:=$(shell uname -m | sed \
)
BOARD:=uml
BOARDNAME:=User Mode Linux
-FEATURES:=ext2
+FEATURES:=ext2 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.30.10
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 7707c76045..7fdb93ce17 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=xburst
BOARDNAME:=XBurst JZ47x0
-FEATURES:=jffs2 tgz ubifs
+FEATURES:=jffs2 tgz ubifs audio
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=2.6.32.7
DEVICE_TYPE=other