aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-07-08 22:44:34 +0000
committerLuka Perkov <luka@openwrt.org>2014-07-08 22:44:34 +0000
commit1b59aa43103e12225949642f9c53c455de4132a5 (patch)
treeb3c8bfaf1bcf2435ac863a970132b32643b1f23a
parent5787156b55216dd241ead36f56f058ff77d92110 (diff)
downloadupstream-1b59aa43103e12225949642f9c53c455de4132a5.tar.gz
upstream-1b59aa43103e12225949642f9c53c455de4132a5.tar.bz2
upstream-1b59aa43103e12225949642f9c53c455de4132a5.zip
kernel: update 3.14 to 3.14.11
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41551 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch2
-rw-r--r--target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch4
-rw-r--r--target/linux/mvebu/Makefile2
-rw-r--r--target/linux/x86_64/Makefile2
5 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 4fc48bf9c1..f72ad424b6 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -23,8 +23,8 @@ endif
ifeq ($(LINUX_VERSION),3.13.7)
LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
endif
-ifeq ($(LINUX_VERSION),3.14.10)
- LINUX_KERNEL_MD5SUM:=3ca34a93c59a788d7f573b2660eb5342
+ifeq ($(LINUX_VERSION),3.14.11)
+ LINUX_KERNEL_MD5SUM:=88b82f8d7a1b04e5cde268e286728226
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch b/target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch
index 9ca8ac1409..0235340aa8 100644
--- a/target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch
+++ b/target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch
@@ -1,6 +1,6 @@
--- a/fs/ubifs/file.c
+++ b/fs/ubifs/file.c
-@@ -1577,6 +1577,10 @@ const struct inode_operations ubifs_syml
+@@ -1576,6 +1576,10 @@ const struct inode_operations ubifs_syml
.follow_link = ubifs_follow_link,
.setattr = ubifs_setattr,
.getattr = ubifs_getattr,
diff --git a/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch b/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
index 8877bc0d42..e4becb38d8 100644
--- a/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
@@ -40,9 +40,9 @@
/*
* Some BIOS implementations leave the Intel GPU interrupts enabled,
* even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -2950,6 +2954,8 @@ static void disable_igfx_irq(struct pci_
- DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0102, disable_igfx_irq);
+@@ -2951,6 +2955,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
+ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
+
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 0252849c06..a2d78df586 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-LINUX_VERSION:=3.14.10
+LINUX_VERSION:=3.14.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86_64/Makefile b/target/linux/x86_64/Makefile
index 600401207d..a029719de1 100644
--- a/target/linux/x86_64/Makefile
+++ b/target/linux/x86_64/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
FEATURES:=ext4 vdi vmdk targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.14.10
+LINUX_VERSION:=3.14.11
KERNELNAME:=bzImage