aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-29 14:41:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-29 14:41:40 +0000
commit4a4e66f9ad9ed987a710f0dc2e6a9eac68754041 (patch)
tree84cdbcb8c9970f7e9f636034a37a050e570ab7fa
parent92568b570251a08cd6ded7ae221fcd86ff538be1 (diff)
downloadupstream-4a4e66f9ad9ed987a710f0dc2e6a9eac68754041.tar.gz
upstream-4a4e66f9ad9ed987a710f0dc2e6a9eac68754041.tar.bz2
upstream-4a4e66f9ad9ed987a710f0dc2e6a9eac68754041.zip
netifd: update to latest version
fixes DNS servers on reload (#12910) fixes ubus object race on reload or down/up (#12612) Backport of r35383 git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@35384 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/netifd/Makefile4
-rwxr-xr-xpackage/netifd/files/sbin/ifstatus2
-rwxr-xr-xpackage/netifd/files/sbin/ifup6
3 files changed, 6 insertions, 6 deletions
diff --git a/package/netifd/Makefile b/package/netifd/Makefile
index 99f26f6b2b..b5dd767f7e 100644
--- a/package/netifd/Makefile
+++ b/package/netifd/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2013-01-28.2
+PKG_VERSION:=2013-01-29.2
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=889f3236fde274d6ebff23fe62c5cd66ed8b3eb7
+PKG_SOURCE_VERSION:=4bb99d4eb462776336928392010b372236ac3c93
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
# PKG_MIRROR_MD5SUM:=
diff --git a/package/netifd/files/sbin/ifstatus b/package/netifd/files/sbin/ifstatus
index 511cc1d8d9..8a951e6e15 100755
--- a/package/netifd/files/sbin/ifstatus
+++ b/package/netifd/files/sbin/ifstatus
@@ -10,4 +10,4 @@ ubus -S list "network.interface.$INTERFACE" >/dev/null || {
echo "Interface $INTERFACE not found"
exit 1
}
-ubus call network.interface."$INTERFACE" status
+ubus call network.interface status "{ \"interface\" : \"$INTERFACE\" }"
diff --git a/package/netifd/files/sbin/ifup b/package/netifd/files/sbin/ifup
index e6dbb35417..af3aaa8453 100755
--- a/package/netifd/files/sbin/ifup
+++ b/package/netifd/files/sbin/ifup
@@ -6,7 +6,7 @@ setup_wifi=
if_call() {
local interface="$1"
for mode in $modes; do
- ubus call $interface $mode
+ ubus call network.interface $mode "{ \"interface\" : \"$interface\" }"
done
}
@@ -38,7 +38,7 @@ done
[ "$modes" = "down up" ] && ubus call network reload
if [ -n "$ifup_all" ]; then
for interface in `ubus -S list 'network.interface.*'`; do
- if_call "$interface"
+ if_call "${interface##network.interface.}"
done
[ -n "$setup_wifi" ] && /sbin/wifi up
exit
@@ -47,7 +47,7 @@ else
echo "Interface $1 not found"
exit
}
- if_call "network.interface.$1"
+ if_call "$1"
fi
if [ -n "$setup_wifi" ] && grep -sq config /etc/config/wireless; then