aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-12 11:53:55 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-12 11:53:55 +0000
commit3a8096afef44a1e76f94b49cfbd5a1451899cc53 (patch)
treedc680497c18c45cb4173a0abc350189b870c3877
parentdd48108ccb8b486f1befa5abd483c66ff1d924ff (diff)
downloadupstream-3a8096afef44a1e76f94b49cfbd5a1451899cc53.tar.gz
upstream-3a8096afef44a1e76f94b49cfbd5a1451899cc53.tar.bz2
upstream-3a8096afef44a1e76f94b49cfbd5a1451899cc53.zip
port iptables fix introduced by changeset:2447 to trunk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2448 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/iptables/Makefile2
-rw-r--r--target/linux/netfilter.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index f54481c05b..cdbb866a09 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -75,7 +75,7 @@ $(IPKG_IPTABLES):
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
- cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y) ipt_standard) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+ cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
)
$(RSTRIP) $(IDIR_IPTABLES)
$(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)
diff --git a/target/linux/netfilter.mk b/target/linux/netfilter.mk
index 433c386d6e..6375a71f21 100644
--- a/target/linux/netfilter.mk
+++ b/target/linux/netfilter.mk
@@ -71,7 +71,7 @@ IPKG_KMOD_IPT_ULOG-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG
#
IPKG_IPTABLES-y := ipt_standard
-IPKG_IPTABLES-y := ipt_icmp ipt_tcp ipt_udp
+IPKG_IPTABLES-y += ipt_icmp ipt_tcp ipt_udp
IPKG_IPTABLES_MOD_CONNTRACK-m :=
IPKG_IPTABLES_MOD_CONNTRACK-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark