aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 20:06:56 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:13 +0100
commitfd35c5b205e7583628472b607ee4eb41c6d1b6d5 (patch)
tree8b0d527866725410ed25cbbb4a7d7361837aa2bb
parentde42466528b4e5748d18af9396a4226b0c1cd0fa (diff)
downloadupstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.tar.gz
upstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.tar.bz2
upstream-fd35c5b205e7583628472b607ee4eb41c6d1b6d5.zip
build: move seama commands to image-commands.mk
Move it to image-commands.mk to get rid of duplicate recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--include/image-commands.mk12
-rw-r--r--target/linux/ar71xx/image/generic.mk11
-rw-r--r--target/linux/ramips/image/Makefile12
3 files changed, 12 insertions, 23 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 65fa36d2be..c5b64c751d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -49,6 +49,18 @@ define Build/eva-image
mv $@.new $@
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ \
+ -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+ -m "signature=$(SEAMA_SIGNATURE)"
+ mv $@.seama $@
+endef
+
define Build/zyxel-ras-image
let \
newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 9f5e755cfe..30a8b34483 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -67,17 +67,6 @@ define Build/relocate-kernel
rm -rf $@.relocate
endef
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ \
- -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
- mv $@.seama $@
-endef
-
-define Build/seama-seal
- $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
- -m "signature=$(SEAMA_SIGNATURE)"
-endef
-
define Build/teltonika-fw-fake-checksum
# Teltonika U-Boot web based firmware upgrade/recovery routine compares
# 16 bytes from md5sum1[16] field in TP-Link v1 header (offset: 76 bytes
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 3c30702ea7..33c4f3132f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -101,18 +101,6 @@ define Build/poray-header
mv $@.new $@
endef
-define Build/seama
- $(STAGING_DIR_HOST)/bin/seama -i $@ \
- -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
- mv $@.seama $@
-endef
-
-define Build/seama-seal
- $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
- -m "signature=$(SEAMA_SIGNATURE)"
- mv $@.seama $@
-endef
-
define Build/wrg-header
mkwrgimg -i $@ -d "/dev/mtdblock/2" -s $(1) -o $@.new
mv $@.new $@