aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-03-20 13:27:16 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-03-22 18:14:28 +0100
commitfa91a147bb25b96be63c61bf87d27cd14d6f7cd7 (patch)
treeee2e04618887104031e275911c80b74ab9c21e24
parent9c63141025ed5554891a1e4ae9be221f64ec0888 (diff)
downloadupstream-fa91a147bb25b96be63c61bf87d27cd14d6f7cd7.tar.gz
upstream-fa91a147bb25b96be63c61bf87d27cd14d6f7cd7.tar.bz2
upstream-fa91a147bb25b96be63c61bf87d27cd14d6f7cd7.zip
kernel: bump 4.9 to 4.9.164
Refreshed all patches. Compile-tested on: ar7 Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm63xx/patches-4.9/001-4.12-07-mdio_bus-Issue-GPIO-RESET-to-PHYs.patch6
-rw-r--r--target/linux/brcm63xx/patches-4.9/001-4.12-08-net-phy-Call-bus-reset-after-releasing-PHYs-from-res.patch4
-rw-r--r--target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch6
4 files changed, 10 insertions, 10 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 9ea94a840c..b80948ca13 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,12 +3,12 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .136
-LINUX_VERSION-4.9 = .163
+LINUX_VERSION-4.9 = .164
LINUX_VERSION-4.14 = .106
LINUX_VERSION-4.19 = .25
LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
-LINUX_KERNEL_HASH-4.9.163 = c27cf9962c17b91275ab9e74b43c1269f726f79e7a85421be7c5c73d267eef91
+LINUX_KERNEL_HASH-4.9.164 = adf598758d3a5390100ea754ccd64668ccd5eebb3507d78e3588d13f3e73f8e7
LINUX_KERNEL_HASH-4.14.106 = a0e2af6add699d86cf15e1ee31ad408aa28dbab82f4462450eba51f90e7d2760
LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
diff --git a/target/linux/brcm63xx/patches-4.9/001-4.12-07-mdio_bus-Issue-GPIO-RESET-to-PHYs.patch b/target/linux/brcm63xx/patches-4.9/001-4.12-07-mdio_bus-Issue-GPIO-RESET-to-PHYs.patch
index a0d2d038cc..eb72f6a82c 100644
--- a/target/linux/brcm63xx/patches-4.9/001-4.12-07-mdio_bus-Issue-GPIO-RESET-to-PHYs.patch
+++ b/target/linux/brcm63xx/patches-4.9/001-4.12-07-mdio_bus-Issue-GPIO-RESET-to-PHYs.patch
@@ -87,7 +87,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (NULL == bus || NULL == bus->name ||
NULL == bus->read || NULL == bus->write)
-@@ -330,6 +334,35 @@ int __mdiobus_register(struct mii_bus *b
+@@ -329,6 +333,35 @@ int __mdiobus_register(struct mii_bus *b
if (bus->reset)
bus->reset(bus);
@@ -123,7 +123,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
for (i = 0; i < PHY_MAX_ADDR; i++) {
if ((bus->phy_mask & (1 << i)) == 0) {
struct phy_device *phydev;
-@@ -355,6 +388,13 @@ error:
+@@ -354,6 +387,13 @@ error:
mdiodev->device_remove(mdiodev);
mdiodev->device_free(mdiodev);
}
@@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
device_del(&bus->dev);
return err;
}
-@@ -376,6 +416,13 @@ void mdiobus_unregister(struct mii_bus *
+@@ -375,6 +415,13 @@ void mdiobus_unregister(struct mii_bus *
mdiodev->device_remove(mdiodev);
mdiodev->device_free(mdiodev);
}
diff --git a/target/linux/brcm63xx/patches-4.9/001-4.12-08-net-phy-Call-bus-reset-after-releasing-PHYs-from-res.patch b/target/linux/brcm63xx/patches-4.9/001-4.12-08-net-phy-Call-bus-reset-after-releasing-PHYs-from-res.patch
index c6eb74a110..182ad62bf8 100644
--- a/target/linux/brcm63xx/patches-4.9/001-4.12-08-net-phy-Call-bus-reset-after-releasing-PHYs-from-res.patch
+++ b/target/linux/brcm63xx/patches-4.9/001-4.12-08-net-phy-Call-bus-reset-after-releasing-PHYs-from-res.patch
@@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/phy/mdio_bus.c
+++ b/drivers/net/phy/mdio_bus.c
-@@ -331,9 +331,6 @@ int __mdiobus_register(struct mii_bus *b
+@@ -330,9 +330,6 @@ int __mdiobus_register(struct mii_bus *b
mutex_init(&bus->mdio_lock);
@@ -31,7 +31,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
/* de-assert bus level PHY GPIO resets */
if (bus->num_reset_gpios > 0) {
bus->reset_gpiod = devm_kcalloc(&bus->dev,
-@@ -363,6 +360,9 @@ int __mdiobus_register(struct mii_bus *b
+@@ -362,6 +359,9 @@ int __mdiobus_register(struct mii_bus *b
}
}
diff --git a/target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch b/target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch
index 217cf4a486..844f747859 100644
--- a/target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch
+++ b/target/linux/generic/hack-4.9/710-phy-add-mdio_register_board_info.patch
@@ -9,7 +9,7 @@
/**
* mdiobus_alloc_size - allocate a mii_bus structure
* @size: extra amount of memory to allocate for private storage.
-@@ -401,6 +403,17 @@ void mdiobus_free(struct mii_bus *bus)
+@@ -400,6 +402,17 @@ void mdiobus_free(struct mii_bus *bus)
}
EXPORT_SYMBOL(mdiobus_free);
@@ -27,7 +27,7 @@
/**
* mdiobus_scan - scan a bus for MDIO devices.
* @bus: mii_bus to scan
-@@ -416,6 +429,7 @@ EXPORT_SYMBOL(mdiobus_free);
+@@ -415,6 +428,7 @@ EXPORT_SYMBOL(mdiobus_free);
struct phy_device *mdiobus_scan(struct mii_bus *bus, int addr)
{
struct phy_device *phydev;
@@ -35,7 +35,7 @@
int err;
phydev = get_phy_device(bus, addr, false);
-@@ -428,6 +442,12 @@ struct phy_device *mdiobus_scan(struct m
+@@ -427,6 +441,12 @@ struct phy_device *mdiobus_scan(struct m
*/
of_mdiobus_link_mdiodev(bus, &phydev->mdio);