aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-01-24 15:32:58 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-02 21:33:07 +0100
commite10ea566cc8fcf51ef0bceff05db374fae8f7e12 (patch)
tree793ba1062a75e7e4f78a55a669c618b94ba49bc9
parent652a13e920af843908b150a7927272ab1a09b3ce (diff)
downloadupstream-e10ea566cc8fcf51ef0bceff05db374fae8f7e12.tar.gz
upstream-e10ea566cc8fcf51ef0bceff05db374fae8f7e12.tar.bz2
upstream-e10ea566cc8fcf51ef0bceff05db374fae8f7e12.zip
mvebu: fix partition type and signature for sdcard
Previously the partition signature was assigned from provided type. Now both are corrected wherein signature is always generated from SOURCE_DATE_EPOCH. With that the root file system can be identified by PARTUUID string, without relying on static declaration of device node. This commit also does some cosmetics, removing trailing whitespace and replacing spaces with tab. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
-rw-r--r--target/linux/mvebu/image/Makefile5
-rwxr-xr-xtarget/linux/mvebu/image/gen_mvebu_sdcard_img.sh6
2 files changed, 7 insertions, 4 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 45ef45abdb..a78269bf1f 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -13,8 +13,10 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x00008000
+SIGNATURE:=$(shell printf "%.8s" $(SOURCE_DATE_EPOCH))
+
define Build/dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
+ $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
endef
# SD-Card Images:
@@ -43,6 +45,7 @@ endef
define Build/sdcard-img
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
+ SIGNATURE="$(SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
"$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
c 32768 $@.boot \
diff --git a/target/linux/mvebu/image/gen_mvebu_sdcard_img.sh b/target/linux/mvebu/image/gen_mvebu_sdcard_img.sh
index 86499eea57..63acc79f40 100755
--- a/target/linux/mvebu/image/gen_mvebu_sdcard_img.sh
+++ b/target/linux/mvebu/image/gen_mvebu_sdcard_img.sh
@@ -1,7 +1,7 @@
#!/usr/bin/env bash
#
# Copyright (C) 2016 Josua Mayer
-#
+#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
@@ -40,7 +40,7 @@ dd if=/dev/zero of="$OUTFILE" bs=512 count=1 >/dev/null
printf "Done\n"
while [ "$#" -ge 3 ]; do
- ptgen_args="$ptgen_args -p $(($2 / 2 + 256)) -S 0x$1"
+ ptgen_args="$ptgen_args -t $1 -p $(($2 / 2 + 256))"
parts="$parts$3 "
shift; shift; shift
done
@@ -50,7 +50,7 @@ sect=63
# create real partition table using fdisk
printf "Creating partition table: "
-set `ptgen -o "$OUTFILE" -h $head -s $sect -l 1024 $ptgen_args`
+set `ptgen -o "$OUTFILE" -h $head -s $sect -l 1024 -S 0x$SIGNATURE $ptgen_args`
printf "Done\n"
# install bootloader