aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-10-30 12:57:43 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-10-31 09:17:14 +0100
commitdf60a0852caf21de6684d38107f32a4eebc4579b (patch)
tree3bdb39b968a2c7e2436009b105591dbbb1a5f3e5
parent0e212220e90db414afa27e304b32cb1f477d7d87 (diff)
downloadupstream-df60a0852caf21de6684d38107f32a4eebc4579b.tar.gz
upstream-df60a0852caf21de6684d38107f32a4eebc4579b.tar.bz2
upstream-df60a0852caf21de6684d38107f32a4eebc4579b.zip
kernel: bump 4.19 to 4.19.81
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch9
-rw-r--r--target/linux/brcm47xx/patches-4.19/159-cpu_fixes.patch10
3 files changed, 10 insertions, 13 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index c37db101e6..912a0cc084 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,11 +8,11 @@ endif
LINUX_VERSION-4.9 = .198
LINUX_VERSION-4.14 = .151
-LINUX_VERSION-4.19 = .80
+LINUX_VERSION-4.19 = .81
LINUX_KERNEL_HASH-4.9.198 = 9572ebfa6ba0efcf9f1ec7b62c7b89baa36a621ab9fd4c5ad025196c549605ac
LINUX_KERNEL_HASH-4.14.151 = ff519c428ee9bbb513a84db5ec32a7e3705cd8c23a57104b25b944cb79583fae
-LINUX_KERNEL_HASH-4.19.80 = 80a9ba764e088aa7fddfef5a97c0236905e291468a37832243b6f3828d36e7ec
+LINUX_KERNEL_HASH-4.19.81 = 293ec1ae0f6b3b4be83a217224b51d137f2163cf2d9d294eecf5d0a354e4e29d
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch b/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
index 2b6af21898..8a1d2f143d 100644
--- a/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
@@ -20,13 +20,10 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
--- a/drivers/net/ethernet/broadcom/genet/bcmmii.c
+++ b/drivers/net/ethernet/broadcom/genet/bcmmii.c
-@@ -280,7 +280,10 @@ int bcmgenet_mii_probe(struct net_device
- int ret;
-
+@@ -286,6 +286,8 @@ int bcmgenet_mii_probe(struct net_device
/* Communicate the integrated PHY revision */
-- phy_flags = priv->gphy_rev;
-+ if (priv->internal_phy)
-+ phy_flags = priv->gphy_rev;
+ if (priv->internal_phy)
+ phy_flags = priv->gphy_rev;
+ else
+ phy_flags = PHY_BRCM_AUTO_PWRDWN_ENABLE;
diff --git a/target/linux/brcm47xx/patches-4.19/159-cpu_fixes.patch b/target/linux/brcm47xx/patches-4.19/159-cpu_fixes.patch
index 0207029ddc..75e493b2dd 100644
--- a/target/linux/brcm47xx/patches-4.19/159-cpu_fixes.patch
+++ b/target/linux/brcm47xx/patches-4.19/159-cpu_fixes.patch
@@ -458,7 +458,7 @@
/*
--- a/arch/mips/mm/tlbex.c
+++ b/arch/mips/mm/tlbex.c
-@@ -972,6 +972,9 @@ void build_get_pgde32(u32 **p, unsigned
+@@ -979,6 +979,9 @@ void build_get_pgde32(u32 **p, unsigned
uasm_i_srl(p, ptr, ptr, SMP_CPUID_PTRSHIFT);
uasm_i_addu(p, ptr, tmp, ptr);
#else
@@ -468,7 +468,7 @@
UASM_i_LA_mostly(p, ptr, pgdc);
#endif
uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -1333,6 +1336,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1340,6 +1343,9 @@ static void build_r4000_tlb_refill_handl
#ifdef CONFIG_64BIT
build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
#else
@@ -478,7 +478,7 @@
build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
#endif
-@@ -1344,6 +1350,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1351,6 +1357,9 @@ static void build_r4000_tlb_refill_handl
build_update_entries(&p, K0, K1);
build_tlb_write_entry(&p, &l, &r, tlb_random);
uasm_l_leave(&l, p);
@@ -488,7 +488,7 @@
uasm_i_eret(&p); /* return from trap */
}
#ifdef CONFIG_MIPS_HUGE_TLB_SUPPORT
-@@ -2039,6 +2048,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -2046,6 +2055,9 @@ build_r4000_tlbchange_handler_head(u32 *
#ifdef CONFIG_64BIT
build_get_pmde64(p, l, r, wr.r1, wr.r2); /* get pmd in ptr */
#else
@@ -498,7 +498,7 @@
build_get_pgde32(p, wr.r1, wr.r2); /* get pgd in ptr */
#endif
-@@ -2085,6 +2097,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -2092,6 +2104,9 @@ build_r4000_tlbchange_handler_tail(u32 *
build_tlb_write_entry(p, l, r, tlb_indexed);
uasm_l_leave(l, *p);
build_restore_work_registers(p);