aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-06-08 11:51:00 +0300
committerJohn Crispin <john@phrozen.org>2018-06-08 12:19:49 +0200
commitc8677ca89e53e3be7988d54280fce166cc894a7e (patch)
tree9acaaf920db38b001d84df155938264dd2a6d3b8
parent8c15fb5240871cbaf806384c3f521b0089645460 (diff)
downloadupstream-c8677ca89e53e3be7988d54280fce166cc894a7e.tar.gz
upstream-c8677ca89e53e3be7988d54280fce166cc894a7e.tar.bz2
upstream-c8677ca89e53e3be7988d54280fce166cc894a7e.zip
ath79: add tl-mr3020-v1 support
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ath79/dts/ar9331.dtsi5
-rw-r--r--target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts (renamed from target/linux/ath79/dts/ar9331_tl_mr3020.dts)95
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk10
5 files changed, 106 insertions, 12 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 80e32d9e00..0ba03b25a0 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -27,6 +27,9 @@ case "$board" in
"glinet,ar150")
ucidef_set_led_wlan "wlan" "WLAN" "gl-ar150:orange:wlan" "phy0tpt"
;;
+"tplink,tl-mr3020-v1")
+ ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x02"
+ ;;
"tplink,tl-wr740n-v2")
ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x02"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index a2d6ab0049..8e3c9177a2 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -26,7 +26,10 @@ ath79_setup_interfaces()
"glinet,ar150")
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;
-
+ "tplink,tl-mr3020-v1")
+ ucidef_set_interface_lan "eth0.1"
+ ucidef_add_switch "switch0" "0@eth0" "1:lan"
+ ;;
"tplink,tl-wdr3600"|\
"tplink,tl-wdr4300")
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/dts/ar9331.dtsi b/target/linux/ath79/dts/ar9331.dtsi
index b29c88a958..5ce755a592 100644
--- a/target/linux/ath79/dts/ar9331.dtsi
+++ b/target/linux/ath79/dts/ar9331.dtsi
@@ -3,4 +3,9 @@
/ {
compatible = "qca,ar9331";
+
+ ref: ref {
+ compatible = "fixed-clock";
+ #clock-cells = <0>;
+ };
};
diff --git a/target/linux/ath79/dts/ar9331_tl_mr3020.dts b/target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts
index 34ee805b33..fc8101564d 100644
--- a/target/linux/ath79/dts/ar9331_tl_mr3020.dts
+++ b/target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts
@@ -7,11 +7,12 @@
#include "ar9331.dtsi"
/ {
- model = "TP-Link TL-MR3020";
- compatible = "tplink,tl-mr3020", "qca,ar9331";
+ model = "TP-Link TL-MR3020 V1";
+ compatible = "tplink,tl-mr3020-v1", "qca,ar9331";
aliases {
serial0 = &uart;
+ led-status = &system;
};
memory@0 {
@@ -26,6 +27,7 @@
label = "tp-link:green:wlan";
gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
default-state = "off";
+ linux,default-trigger = "phy0tpt";
};
lan {
@@ -34,7 +36,7 @@
default-state = "off";
};
- wps {
+ system: wps {
label = "tp-link:green:wps";
gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
default-state = "off";
@@ -44,31 +46,37 @@
label = "tp-link:green:3g";
gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
default-state = "off";
+ trigger-sources = <&hub_port>;
+ linux,default-trigger = "usbport";
};
};
keys {
- compatible = "gpio-keys-polled";
+ compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <100>;
- button@0 {
- label = "wps";
- linux,code = <KEY_WPS_BUTTON>;
+ button0 {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
};
- button@1 {
+ button1 {
label = "sw1";
+ linux,input-type = <EV_SW>;
linux,code = <BTN_0>;
gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
};
- button@2 {
+ button2 {
label = "sw2";
+ linux,input-type = <EV_SW>;
linux,code = <BTN_1>;
gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
};
};
@@ -98,6 +106,11 @@
dr_mode = "host";
vbus-supply = <&reg_usb_vbus>;
status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
};
&usb_phy {
@@ -112,8 +125,68 @@
spiflash: s25sl032p@0 {
#address-cells = <1>;
#size-cells = <1>;
- compatible = "spansion,s25sl032p", "jedec,spi-nor";
+ compatible = "jedec,spi-nor";
spi-max-frequency = <104000000>;
reg = <0>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x020000 0x3c0000>;
+ };
+
+ partition@3e0000 {
+ label = "config";
+ reg = <0x3e0000 0x010000>;
+ read-only;
+ };
+
+ art: partition@3f0000 {
+ label = "art";
+ reg = <0x3f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio1 {
+ status = "okay";
+ phy4: ethernet-phy@4 {
+ reg = <4>;
};
};
+
+&eth1 {
+ status = "okay";
+ phy-handle = <&phy4>;
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+
+ gmac-config {
+ device = <&gmac>;
+
+ switch-phy-addr-swap = <1>;
+ switch-phy-swap = <1>;
+ };
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index f92c7d9644..1dfed48dba 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -11,6 +11,16 @@ define Device/tl-mr10u
endef
TARGET_DEVICES += tl-mr10u
+define Device/tl-mr3020-v1
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := TP-LINK TL-MR3020 v1
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x30200001
+ SUPPORTED_DEVICES := tplink,tl-mr3020-v1 tl-mr3020-v1
+endef
+TARGET_DEVICES += tl-mr3020-v1
+
define Device/tl-wr703n
$(Device/tplink-4mlzma)
ATH_SOC := ar9331