aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-24 17:03:03 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-24 17:03:03 +0000
commitc4d517c7bb39efbc58f29f345bd1cf677ca8527f (patch)
tree424dd99d0b40c70f27214236f6f2f5c270006d01
parent264ac83490d1c9844acc677af43b3a0de8868a30 (diff)
downloadupstream-c4d517c7bb39efbc58f29f345bd1cf677ca8527f.tar.gz
upstream-c4d517c7bb39efbc58f29f345bd1cf677ca8527f.tar.bz2
upstream-c4d517c7bb39efbc58f29f345bd1cf677ca8527f.zip
use 2.6.27.7
SVN-Revision: 16968
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/brcm63xx/Makefile6
-rw-r--r--target/linux/generic-2.6/config-2.6.271
-rw-r--r--target/linux/olpc/Makefile2
5 files changed, 8 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 64209e3652..c26581259c 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -19,8 +19,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.25.20)
LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
endif
-ifeq ($(LINUX_VERSION),2.6.27.26)
- LINUX_KERNEL_MD5SUM:=6c246d71fa4698fb0dee0ed092f0282b
+ifeq ($(LINUX_VERSION),2.6.27.27)
+ LINUX_KERNEL_MD5SUM:=69c2ec59da6fcc0d2dfb4c470a721957
endif
ifeq ($(LINUX_VERSION),2.6.28.10)
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index b6055d1f75..34c618d43e 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.27.26
+LINUX_VERSION:=2.6.27.27
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 200040b0bc..a6b04c6d4e 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.27.26
+LINUX_VERSION:=2.6.27.27
include $(INCLUDE_DIR)/target.mk
@@ -18,7 +18,7 @@ DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
define Target/Description
Build firmware images for Broadcom based xDSL/routers
- currently supports BCM6348 and BCM6358 based devices.
+ currently supports BCM6338, BCM6348 and BCM6358 based devices.
(e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
endef
diff --git a/target/linux/generic-2.6/config-2.6.27 b/target/linux/generic-2.6/config-2.6.27
index 8da33dc52e..cb6f2f9355 100644
--- a/target/linux/generic-2.6/config-2.6.27
+++ b/target/linux/generic-2.6/config-2.6.27
@@ -367,6 +367,7 @@ CONFIG_DEFAULT_DEADLINE=y
# CONFIG_DEFAULT_HTCP is not set
CONFIG_DEFAULT_IOSCHED="deadline"
# CONFIG_DEFAULT_NOOP is not set
+CONFIG_DEFAULT_MMAP_MIN_ADDR=4096
# CONFIG_DEFAULT_RENO is not set
CONFIG_DEFAULT_TCP_CONG="westwood"
# CONFIG_DEFAULT_VEGAS is not set
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
index c1e2da146d..ab98c1e0c8 100644
--- a/target/linux/olpc/Makefile
+++ b/target/linux/olpc/Makefile
@@ -11,7 +11,7 @@ BOARD:=olpc
BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2
-LINUX_VERSION:=2.6.27.26
+LINUX_VERSION:=2.6.27.27
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci