aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamille Bilodeau <camille.bilodeau@protonmail.com>2017-06-13 10:05:13 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commitbb46b635df48d5c2368f98646c16e3333cbc11fb (patch)
treeded054933b8b2a7c9089186caa2e12ba73c00c0a
parent2fa58a8d7c340cd6b9c1d9be401d43a2ac8125e3 (diff)
downloadupstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.gz
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.bz2
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.zip
ar71xx: move Arduino Yun to generic building code
Migrate Arduino Yun from legacy to generic building code. Note: the mtd partitioning is changed to adopt the LEDE default partitioning. It allows to have a kernel bigger than 1280k. It is necessary as kernel > 4.4 with default LEDE configuration grows bigger. To use the new partitioning, you need to update your U-Boot env in advance: setenv mtdparts "spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro" setenv bootcmd "run addboard; run addtty; run addparts; run addrootfs; bootm 0x9f050000 || bootm 0x9fea0000" saveenv Signed-off-by: Camille Bilodeau <camille.bilodeau@protonmail.com>
-rw-r--r--target/linux/ar71xx/image/generic.mk10
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk6
-rw-r--r--target/linux/ar71xx/image/legacy.mk2
3 files changed, 10 insertions, 8 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 56dcf5c997..5a7a509fbd 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -92,6 +92,16 @@ define Device/ap90q
endef
TARGET_DEVICES += ap90q
+define Device/arduino-yun
+ DEVICE_TITLE := Arduino Yun
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME := Yun
+ IMAGE_SIZE := 15936k
+ CONSOLE = ttyATH0,250000
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro
+endef
+TARGET_DEVICES += arduino-yun
+
define Device/bsb
DEVICE_TITLE := Smart Electronics Black Swift board
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index e3aeb592bd..77230249af 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -167,12 +167,6 @@ define LegacyDevice/WLR8100
endef
LEGACY_DEVICES += WLR8100
-define LegacyDevice/YUN_16M
- DEVICE_TITLE := Arduino Yun based on Atheros AR9331 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
-endef
-LEGACY_DEVICES += YUN_16M
-
define LegacyDevice/F9K1115V2
DEVICE_TITLE := Belkin AC1750DB (F9K1115V2)
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb3 kmod-usb-ledtrig-usbport \
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 2f1a400945..b400e5ddbb 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -277,7 +277,6 @@ wndr4300_mtdlayout=mtdparts=ar934x-nfc:256k(u-boot)ro,256k(u-boot-env)ro,256k(ca
zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
mynet_rext_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,7808k(firmware),64k(nvram)ro,64k(ART)ro
zyx_nbg6716_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(env)ro,64k(RFdata)ro,-(nbu);ar934x-nfc:2048k(zyxel_rfsd),2048k(romd),1024k(header),2048k(kernel),-(ubi)
-yun_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14656k(rootfs),1280k(kernel),64k(nvram),64k(art)ro,15936k@0x50000(firmware)
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
@@ -904,7 +903,6 @@ $(eval $(call SingleProfile,AthLzma,64k,EWDORIN16M,ew-dorin-16M,EW-DORIN,ttyATH0
$(eval $(call SingleProfile,AthLzma,64k,HORNETUBx2,hornet-ub-x2,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_16M),KRuImage,65536))
$(eval $(call SingleProfile,AthLzma,64k,TUBE2H16M,tube2h-16M,TUBE2H,ttyATH0,115200,$$(alfa_mtdlayout_16M),KRuImage,65536))
$(eval $(call SingleProfile,AthLzma,64k,WLR8100,wlr8100,WLR8100,ttyS0,115200,$$(wlr8100_mtdlayout),KRuImage))
-$(eval $(call SingleProfile,AthLzma,64k,YUN_16M,yun-16M,Yun,ttyATH0,250000,$$(yun_mtdlayout_16M),RKuImage))
$(eval $(call SingleProfile,Belkin,64k,F9K1115V2,f9k1115v2,F9K1115V2,ttyS0,115200,$$(f9k1115v2_mtdlayout),BR-6679BAC))