aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrique Giraldo <enrique.giraldo@galgus.net>2017-08-02 17:08:32 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-09-10 22:15:04 +0200
commitb8b410fba3b1ecc027b75285c64b73fa7f12ea0c (patch)
treef2962e96c2d79cad025bc5d77ee467c46843a43a
parent71067e3b79a0d3b7f9af29c8ce9670196f6d4e81 (diff)
downloadupstream-b8b410fba3b1ecc027b75285c64b73fa7f12ea0c.tar.gz
upstream-b8b410fba3b1ecc027b75285c64b73fa7f12ea0c.tar.bz2
upstream-b8b410fba3b1ecc027b75285c64b73fa7f12ea0c.zip
ar71xx: add metadata to wpj344 and wpj558 images
This adds metadata to wpj344 and wpj558 images to prevent loading firmware of wpj344 into wpj558 and vice versa. This until now was possible and break the units and had to be recovered from the uboot. Signed-off-by: Enrique Giraldo <enrique.giraldo@galgus.net>
-rw-r--r--target/linux/ar71xx/image/generic.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 726b03a04c..3352d156ac 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -874,6 +874,9 @@ define Device/wpj344
$(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ344 (16MB flash)
BOARDNAME := WPJ344
+ SUPPORTED_DEVICES := wpj344
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
define Device/wpj531
@@ -886,6 +889,9 @@ define Device/wpj558
$(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ558 (16MB flash)
BOARDNAME := WPJ558
+ SUPPORTED_DEVICES := wpj558
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
define Device/wpj563