aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-05-21 15:22:00 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 07:20:26 +0200
commitae8ff1c65c4ea4e0b2e1e8ef94fad87587d979bc (patch)
tree7df826f218d293a9fcb2bb362fcc640bbf0b90d7
parent06116473cca4ee765978aa3035eab321cd57bd71 (diff)
downloadupstream-ae8ff1c65c4ea4e0b2e1e8ef94fad87587d979bc.tar.gz
upstream-ae8ff1c65c4ea4e0b2e1e8ef94fad87587d979bc.tar.bz2
upstream-ae8ff1c65c4ea4e0b2e1e8ef94fad87587d979bc.zip
ar71xx: Fix build for dap-1330-a1 board
Using a version number of 16 character causes a buffer overflow in the version number overwriting the first bit of the signature in the mkdapimg2 tool. I am not sure if the version number should be null terminated or not. This patch reduces the size of the version number by removing the number of private commits from it. This was the original version number which caused problems: OpenWrt-r6727+10 Now it uses this version number: OpenWrt-r6727 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/ar71xx/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index a0f6326145..020e01f85a 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -36,7 +36,7 @@ define Build/mkdapimg2
$(STAGING_DIR_HOST)/bin/mkdapimg2 \
-i $@ -o $@.new \
-s $(DAP_SIGNATURE) \
- -v $(VERSION_DIST)-$(firstword $(subst -, ,$(REVISION))) \
+ -v $(VERSION_DIST)-$(firstword $(subst +, ,$(firstword $(subst -, ,$(REVISION))))) \
-r Default \
$(if $(1),-k $(1))
mv $@.new $@