aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-03 10:58:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-03 10:58:50 +0000
commita5209e63ef8682fcc2ce30a918b2f91f85364c54 (patch)
tree71b45989dba90ce2933042cdac877d919f4b5470
parenta102009792aa8a1318d5794b60b015b6c630f868 (diff)
downloadupstream-a5209e63ef8682fcc2ce30a918b2f91f85364c54.tar.gz
upstream-a5209e63ef8682fcc2ce30a918b2f91f85364c54.tar.bz2
upstream-a5209e63ef8682fcc2ce30a918b2f91f85364c54.zip
Add support for Sierra Wireless (#1620)
SVN-Revision: 7086
-rw-r--r--package/kernel/modules/usb.mk12
-rw-r--r--target/linux/brcm47xx-2.6/config/default32
2 files changed, 12 insertions, 32 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index d5af3d92b5..b7d5cc4dad 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -228,6 +228,18 @@ endef
$(eval $(call KernelPackage,usb-serial-pl2303))
+define KernelPackage/usb-serial-sierrawireless
+ TITLE:=Support for Sierra Wireless devices
+ DESCRIPTION:=Kernel support for Sierra Wireless devices
+ DEPENDS:=kmod-usb-serial
+ SUBMENU:=$(USBMENU)
+ KCONFIG:=$(CONFIG_USB_SERIAL_SIERRAWIRELESS)
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/sierra.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,65,sierra)
+endef
+$(eval $(call KernelPackage,usb-serial-sierrawireless))
+
+
define KernelPackage/usb-serial-visor
TITLE:=Support for Handspring Visor devices
DESCRIPTION:=Kernel support for Handspring Visor PDAs
diff --git a/target/linux/brcm47xx-2.6/config/default b/target/linux/brcm47xx-2.6/config/default
index d5c74d17d3..488253a9a5 100644
--- a/target/linux/brcm47xx-2.6/config/default
+++ b/target/linux/brcm47xx-2.6/config/default
@@ -277,38 +277,6 @@ CONFIG_USB_EHCI_SPLIT_ISO=y
CONFIG_USB_OHCI_HCD=m
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
-# CONFIG_USB_SERIAL_AIRCABLE is not set
-# CONFIG_USB_SERIAL_AIRPRIME is not set
-# CONFIG_USB_SERIAL_ARK3116 is not set
-# CONFIG_USB_SERIAL_CP2101 is not set
-# CONFIG_USB_SERIAL_CYBERJACK is not set
-# CONFIG_USB_SERIAL_CYPRESS_M8 is not set
-# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
-# CONFIG_USB_SERIAL_EDGEPORT is not set
-# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
-# CONFIG_USB_SERIAL_EMPEG is not set
-# CONFIG_USB_SERIAL_FUNSOFT is not set
-# CONFIG_USB_SERIAL_GARMIN is not set
-# CONFIG_USB_SERIAL_GENERIC is not set
-# CONFIG_USB_SERIAL_HP4X is not set
-# CONFIG_USB_SERIAL_IPAQ is not set
-# CONFIG_USB_SERIAL_IPW is not set
-# CONFIG_USB_SERIAL_IR is not set
-# CONFIG_USB_SERIAL_KEYSPAN is not set
-# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
-# CONFIG_USB_SERIAL_KLSI is not set
-# CONFIG_USB_SERIAL_KOBIL_SCT is not set
-# CONFIG_USB_SERIAL_MCT_U232 is not set
-# CONFIG_USB_SERIAL_MOS7720 is not set
-# CONFIG_USB_SERIAL_MOS7840 is not set
-# CONFIG_USB_SERIAL_NAVMAN is not set
-# CONFIG_USB_SERIAL_OMNINET is not set
-# CONFIG_USB_SERIAL_OPTION is not set
-# CONFIG_USB_SERIAL_SAFE is not set
-# CONFIG_USB_SERIAL_SIERRAWIRELESS is not set
-# CONFIG_USB_SERIAL_TI is not set
-# CONFIG_USB_SERIAL_WHITEHEAT is not set
-# CONFIG_USB_SERIAL_XIRCOM is not set
# CONFIG_USB_STORAGE_ALAUDA is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_DPCM is not set