aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-04-01 12:27:46 +0200
committerMathias Kresin <dev@kresin.me>2017-04-21 07:47:59 +0200
commit9e468f7829eb6bfeff2a3671b04e53003a709313 (patch)
treece031e1dcadae813cac2e106a6eb0c8698ffa680
parentc6fe325587b1955f84c339a2ae17da28dc4e6bec (diff)
downloadupstream-9e468f7829eb6bfeff2a3671b04e53003a709313.tar.gz
upstream-9e468f7829eb6bfeff2a3671b04e53003a709313.tar.bz2
upstream-9e468f7829eb6bfeff2a3671b04e53003a709313.zip
ramips: add former used board names to metadata
We need to keep the former used (unmodified) boardname in the metadata. Otherwise an upgrade from an board using the old boardname will be refused. Fixes: a75ce960ac1b ("ramips: use different board names for variants") Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--target/linux/ramips/image/mt7620.mk2
-rw-r--r--target/linux/ramips/image/rt305x.mk6
2 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index fcecb7a1c8..dd88d5043e 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -418,6 +418,7 @@ define Device/wt3020-4M
BLOCKSIZE := 4k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
IMAGES += factory.bin
+ SUPPORTED_DEVICES += wt3020
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
poray-header -B WT3020 -F 4M
DEVICE_TITLE := Nexx WT3020 (4MB)
@@ -427,6 +428,7 @@ TARGET_DEVICES += wt3020-4M
define Device/wt3020-8M
DTS := WT3020-8M
IMAGES += factory.bin
+ SUPPORTED_DEVICES += wt3020
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
poray-header -B WT3020 -F 8M
DEVICE_TITLE := Nexx WT3020 (8MB)
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 55c47e3467..69533ce9e7 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -111,6 +111,7 @@ TARGET_DEVICES += all5003
define Device/asl26555-8M
DTS := ASL26555-8M
IMAGE_SIZE := 7744k
+ SUPPORTED_DEVICES += asl26555
DEVICE_TITLE := Alpha ASL26555
DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport
endef
@@ -119,6 +120,7 @@ TARGET_DEVICES += asl26555-8M
define Device/asl26555-16M
DTS := ASL26555-16M
IMAGE_SIZE := 15872k
+ SUPPORTED_DEVICES += asl26555
DEVICE_TITLE := Alpha ASL26555 16M
DEVICE_PACKAGES :=
endef
@@ -538,6 +540,7 @@ TARGET_DEVICES += ncs601w
define Device/nixcore-x1-8M
DTS := NIXCORE-8M
IMAGE_SIZE := 7872k
+ SUPPORTED_DEVICES += nixcore-x1
DEVICE_TITLE := NixcoreX1 (8M)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
endef
@@ -546,6 +549,7 @@ TARGET_DEVICES += nixcore-x1-8M
define Device/nixcore-x1-16M
DTS := NIXCORE-16M
IMAGE_SIZE := 16064k
+ SUPPORTED_DEVICES += nixcore-x1
DEVICE_TITLE := NixcoreX1 (16M)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
endef
@@ -679,6 +683,7 @@ TARGET_DEVICES += v22rw-2x2
define Device/vocore-8M
DTS := VOCORE-8M
IMAGE_SIZE := 7872k
+ SUPPORTED_DEVICES += vocore
DEVICE_TITLE := VoCore (8M)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-ralink \
@@ -689,6 +694,7 @@ TARGET_DEVICES += vocore-8M
define Device/vocore-16M
DTS := VOCORE-16M
IMAGE_SIZE := 16064k
+ SUPPORTED_DEVICES += vocore
DEVICE_TITLE := VoCore (16M)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
kmod-i2c-core kmod-i2c-ralink \