aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:17 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:17 +0000
commit929ade064862bddfb3cabaf00dce8a5b7607e23c (patch)
treec62cdedd5ad0c4d884713d1443250bcdfdddba54
parent712f6ec52abc4e8a04611bda0604dc9e8b658e6f (diff)
downloadupstream-929ade064862bddfb3cabaf00dce8a5b7607e23c.tar.gz
upstream-929ade064862bddfb3cabaf00dce8a5b7607e23c.tar.bz2
upstream-929ade064862bddfb3cabaf00dce8a5b7607e23c.zip
brcm63xx: add DT support for CPVA642
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43570
-rw-r--r--target/linux/brcm63xx/dts/cpva642.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
-rw-r--r--target/linux/brcm63xx/patches-3.14/503-board-CPVA642.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/503-board-CPVA642.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch2
-rw-r--r--target/linux/brcm63xx/profiles/telsey.mk16
7 files changed, 66 insertions, 5 deletions
diff --git a/target/linux/brcm63xx/dts/cpva642.dts b/target/linux/brcm63xx/dts/cpva642.dts
new file mode 100644
index 0000000000..a12dd816a3
--- /dev/null
+++ b/target/linux/brcm63xx/dts/cpva642.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Telsey CPVA642-type (CPA-ZNTE60T)";
+ compatible = "telsey,cpva642", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ linux@10000 {
+ label = "linux";
+ reg = <0x010000 0x7e0000>;
+ };
+
+ nvram@7f0000 {
+ label = "nvram";
+ reg = <0x7f0000 0x010000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 939d8e0681..30fb36335f 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -215,9 +215,6 @@ define Image/Build
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
- # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
- $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
-
# Netgear CVG834G
$(call Image/Build/HCS,$(1),cvg834g,a020,0001,0022,$(KDIR)/vmlinux)
@@ -330,6 +327,8 @@ $(eval $(call ImageDTB,CFEDTB,SPW500V,spw500v,96348GW,6348,SPW500V))
$(eval $(call ImageDTB,CFEDTB,GW6000,gw6000,96348GW,6348,GW6000))
# Tecom GW6200
$(eval $(call ImageDTB,CFEDTB,GW6200,gw6200,96348GW,6348,GW6200,--rsa-signature "$(shell printf '\x99')"))
+# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
+$(eval $(call ImageDTB,CFEDTB,CPVA642,cpva642,CPVA642,6358,CPA-ZNTE60T,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0" --pad 4))
# SFR Neufbox 4
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-ser-r0,96358VW,6358,NEUFBOX4-SER,--rsa-signature "OpenWRT-$(REVISION)"))
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))
diff --git a/target/linux/brcm63xx/patches-3.14/503-board-CPVA642.patch b/target/linux/brcm63xx/patches-3.14/503-board-CPVA642.patch
index 8b5ad5cb0f..0a1ccbdf63 100644
--- a/target/linux/brcm63xx/patches-3.14/503-board-CPVA642.patch
+++ b/target/linux/brcm63xx/patches-3.14/503-board-CPVA642.patch
@@ -107,3 +107,11 @@
&board_DWVS0,
&board_nb4_ser_r0,
&board_nb4_fxc_r1,
+@@ -1132,6 +1225,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
+ { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
+ { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
++ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6368
+ #endif
diff --git a/target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch b/target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
index 49564dcae6..e8550890e6 100644
--- a/target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
+++ b/target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
@@ -86,6 +86,6 @@
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
+ { .compatible = "t-com,spw303v", .data = &board_spw303v, },
+ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
- #endif
diff --git a/target/linux/brcm63xx/patches-3.18/503-board-CPVA642.patch b/target/linux/brcm63xx/patches-3.18/503-board-CPVA642.patch
index 8b5ad5cb0f..0a1ccbdf63 100644
--- a/target/linux/brcm63xx/patches-3.18/503-board-CPVA642.patch
+++ b/target/linux/brcm63xx/patches-3.18/503-board-CPVA642.patch
@@ -107,3 +107,11 @@
&board_DWVS0,
&board_nb4_ser_r0,
&board_nb4_fxc_r1,
+@@ -1132,6 +1225,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
+ { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
+ { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
++ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6368
+ #endif
diff --git a/target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch b/target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch
index 49564dcae6..e8550890e6 100644
--- a/target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch
+++ b/target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch
@@ -86,6 +86,6 @@
{ .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
{ .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
+ { .compatible = "t-com,spw303v", .data = &board_spw303v, },
+ { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
#endif
#ifdef CONFIG_BCM63XX_CPU_6368
- #endif
diff --git a/target/linux/brcm63xx/profiles/telsey.mk b/target/linux/brcm63xx/profiles/telsey.mk
new file mode 100644
index 0000000000..5e2359aa0d
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/telsey.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CPVA642
+ NAME:=Telsey CPVA642-type (CPA-ZNTE60T)
+ PACKAGES:=kmod-rt61-pci wpad-mini\
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/CPVA642/Description
+ Package set optimized for CPVA642-type.
+endef
+$(eval $(call Profile,CPVA642))