aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-15 11:09:53 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-16 10:06:45 +0200
commit912340033a58f881a1ee6b0c4b04ef58230d9e08 (patch)
tree62f3ceeb527bc598979437aa2fa2e24bd10cf5f3
parentb8bc672f247a68bc6f72f08f9352cd7aaa5cb9c4 (diff)
downloadupstream-912340033a58f881a1ee6b0c4b04ef58230d9e08.tar.gz
upstream-912340033a58f881a1ee6b0c4b04ef58230d9e08.tar.bz2
upstream-912340033a58f881a1ee6b0c4b04ef58230d9e08.zip
kernel: bump 3.18 to 3.18.124
Refreshed all patches. Compile-tested: adm5120 Runtime-tested: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch8
-rw-r--r--target/linux/generic/pending-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch2
3 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 5d5a7ce663..21f7510f2c 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,11 +2,11 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .123
+LINUX_VERSION-3.18 = .124
LINUX_VERSION-4.9 = .132
LINUX_VERSION-4.14 = .75
-LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
+LINUX_KERNEL_HASH-3.18.124 = 25d2a5abd627534a1e51d028890c184aad8e628c345c5fe0cc0f9d7c31b7a5a3
LINUX_KERNEL_HASH-4.9.132 = 67e66ae14595b3c93f228c417463e5436b9d64f5e9dfd3b92b7e24714d1ee5d3
LINUX_KERNEL_HASH-4.14.75 = 5093d7230b8f1c553450ca6c1ccd20a46a055d9277a7e161039a8642b3398120
diff --git a/target/linux/generic/pending-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch b/target/linux/generic/pending-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch
index 51f31ea06e..8990061303 100644
--- a/target/linux/generic/pending-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch
+++ b/target/linux/generic/pending-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch
@@ -44,7 +44,7 @@ Closes 20532
--- a/net/ipv6/ip6_output.c
+++ b/net/ipv6/ip6_output.c
-@@ -602,20 +602,22 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -603,20 +603,22 @@ int ip6_fragment(struct sk_buff *skb, in
}
mtu -= hlen + sizeof(struct frag_hdr);
@@ -69,7 +69,7 @@ Closes 20532
goto slow_path_clean;
/* Partially cloned skb? */
-@@ -632,8 +634,6 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -633,8 +635,6 @@ int ip6_fragment(struct sk_buff *skb, in
err = 0;
offset = 0;
@@ -78,7 +78,7 @@ Closes 20532
/* BUILD HEADER */
*prevhdr = NEXTHDR_FRAGMENT;
-@@ -641,8 +641,11 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -642,8 +642,11 @@ int ip6_fragment(struct sk_buff *skb, in
if (!tmp_hdr) {
IP6_INC_STATS(net, ip6_dst_idev(skb_dst(skb)),
IPSTATS_MIB_FRAGFAILS);
@@ -91,7 +91,7 @@ Closes 20532
__skb_pull(skb, hlen);
fh = (struct frag_hdr *)__skb_push(skb, sizeof(struct frag_hdr));
-@@ -740,7 +743,6 @@ slow_path:
+@@ -741,7 +744,6 @@ slow_path:
*/
*prevhdr = NEXTHDR_FRAGMENT;
diff --git a/target/linux/generic/pending-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch b/target/linux/generic/pending-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch
index 95d3578139..61612cecb8 100644
--- a/target/linux/generic/pending-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch
+++ b/target/linux/generic/pending-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch
@@ -26,7 +26,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/net/ipv6/ip6_output.c
+++ b/net/ipv6/ip6_output.c
-@@ -908,21 +908,45 @@ static int ip6_dst_lookup_tail(struct so
+@@ -909,21 +909,45 @@ static int ip6_dst_lookup_tail(struct so
#endif
int err;