aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:45 +0000
commit907fb8d8e560584ca9fec1128657a867cfb0dac9 (patch)
tree81c15aa9dc4bc4177f47d50fdcc39bb4ba061639
parentb0bf5fd9a078590c51cc8e3d5e7794e150f62104 (diff)
downloadupstream-907fb8d8e560584ca9fec1128657a867cfb0dac9.tar.gz
upstream-907fb8d8e560584ca9fec1128657a867cfb0dac9.tar.bz2
upstream-907fb8d8e560584ca9fec1128657a867cfb0dac9.zip
install static libraries from uclibc to the rootfs staging dir
SVN-Revision: 17169
-rw-r--r--package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 2c88458af4..6901829f29 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -247,6 +247,10 @@ define Package/libc/install
$(call Package/$(LIBC)/install,$1)
endef
+define Package/libc/install_lib
+ $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+endef
+
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(TOOLCHAIN_DIR)/lib/libpthread.so.* $(1)/lib/