aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-07 06:55:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-07 06:55:50 +0000
commit6e69765559ed8993db5ac8697d944e80abcda57d (patch)
treeb298b9a06d4878a48c1c894e9c07b1e731f431b7
parent8eb8a6e1e7cec83cbb3a3d4a7486f0e5205a1b98 (diff)
downloadupstream-6e69765559ed8993db5ac8697d944e80abcda57d.tar.gz
upstream-6e69765559ed8993db5ac8697d944e80abcda57d.tar.bz2
upstream-6e69765559ed8993db5ac8697d944e80abcda57d.zip
ar71xx: fix WNDR3x00 factory image generation
Factory images for WNDR3700v2 and WNDR3800 should contain these model IDs for the device: field in their DNI tags, not WNDR3700. This regressed in r29434, which redid WNDR3x00 model detection. The sixth parameter to Image/Build/Netgear is only used as the -B argument to mkdniimg, which is used to set the device: field. In r29434, this was erroneously changed to be WNDR3700 for all models. The tools to flash factory images (U-Boot's TFTP server and the factory software's upgrade utility) may refuse to honor images with incorrect device: fields in their DNI tags. Signed-off-by: Mark Mentovai <mark@moxienet.com> SVN-Revision: 29473
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 324899d40f..a58f53ac61 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -795,8 +795,8 @@ wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kerne
wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
define Image/Build/Profile/WNDR3700
$(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700,$(wndr3700_cmdline),$(wndr3700_mtdlayout),3700,WNDR3700,"" NA,)
- $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700v2,$(wndr3700_cmdline),$(wndr3700v2_mtdlayout),3701,WNDR3700,"",-H 29763654+16+64)
- $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3800,$(wndr3700_cmdline),$(wndr3700v2_mtdlayout),3701,WNDR3700,"",-H 29763654+16+128)
+ $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3700v2,$(wndr3700_cmdline),$(wndr3700v2_mtdlayout),3701,WNDR3700v2,"",-H 29763654+16+64)
+ $(call Image/Build/Template/$(fs_64k)/$(1),Netgear,wndr3800,$(wndr3700_cmdline),$(wndr3700v2_mtdlayout),3701,WNDR3800,"",-H 29763654+16+128)
endef
wr400n_cmdline=board=WRT400N console=ttyS0,115200