aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>2019-01-09 20:54:34 +0800
committerChristian Lamparter <chunkeey@gmail.com>2019-02-05 19:37:30 +0100
commit6621da55b7a8e4db07ac3104b4304a508336741c (patch)
treea1c32d8c3c8c7ccebf49ca9374c9f774e15f2649
parent9f90074db72a731abe7ab9125a367c71cf75bec6 (diff)
downloadupstream-6621da55b7a8e4db07ac3104b4304a508336741c.tar.gz
upstream-6621da55b7a8e4db07ac3104b4304a508336741c.tar.bz2
upstream-6621da55b7a8e4db07ac3104b4304a508336741c.zip
ramips: enable MT7610E 5GHz radio of MT7620a_MT7610e EVB
This enables MT7610E of the EVB Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
-rw-r--r--target/linux/ramips/dts/MT7620a_MT7610e.dts8
-rw-r--r--target/linux/ramips/image/mt7620.mk1
2 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/MT7620a_MT7610e.dts b/target/linux/ramips/dts/MT7620a_MT7610e.dts
index f90ba851be..e0ae57a0d9 100644
--- a/target/linux/ramips/dts/MT7620a_MT7610e.dts
+++ b/target/linux/ramips/dts/MT7620a_MT7610e.dts
@@ -89,3 +89,11 @@
&pcie {
status = "okay";
};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index e487f529d6..57903232ed 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -431,6 +431,7 @@ TARGET_DEVICES += mt7620a_mt7530
define Device/mt7620a_mt7610e
DTS := MT7620a_MT7610e
DEVICE_TITLE := MediaTek MT7620a + MT7610e EVB
+ DEVICE_PACKAGES := kmod-mt76x0e
SUPPORTED_DEVICES := mt7620a_mt7610e
endef
TARGET_DEVICES += mt7620a_mt7610e