aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-07-19 09:48:56 +0300
committerJohn Crispin <john@phrozen.org>2018-07-30 11:03:02 +0200
commit40f66f1431b1a6638f05b75952d7b5a94e385e8d (patch)
treeb5878179ab4bd39816e2a8806d438b3a0c194355
parentf9af9be8abb72838011c206029ee9274ccd8738e (diff)
downloadupstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.tar.gz
upstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.tar.bz2
upstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.zip
omap: rename image for sysupgrade compatibility
for sysupgrade to work we need to change the image name based on dts target name Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
-rw-r--r--package/boot/uboot-omap/Makefile10
-rw-r--r--target/linux/omap/image/Makefile18
2 files changed, 14 insertions, 14 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 0d5260d121..69f234d182 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2017.01
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_HASH:=6c425175f93a4bcf2ec9faf5658ef279633dbd7856a293d95bd1ff516528ecf2
@@ -24,17 +24,17 @@ endef
define U-Boot/omap4_panda
NAME:=Pandaboard
- BUILD_DEVICES:=omap4-panda
+ BUILD_DEVICES:=ti_omap4-panda
endef
define U-Boot/am335x_boneblack
NAME:=TI AM335x BeagleBone Black
- BUILD_DEVICES:=am335x-boneblack
+ BUILD_DEVICES:=ti_am335x-bone-black
endef
define U-Boot/am335x_evm
NAME:=AM335x EVM
- BUILD_DEVICES:=am335x-evm
+ BUILD_DEVICES:=ti_am335x-evm
endef
define U-Boot/omap3_overo
@@ -43,7 +43,7 @@ endef
define U-Boot/omap3_beagle
NAME:=BeagleBoard
- BUILD_DEVICES:=omap3-beagle
+ BUILD_DEVICES:=ti_omap3-beagle
endef
UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle am335x_boneblack
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index 2f1e5b5ac0..c7271aba8f 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -38,34 +38,34 @@ define Device/Default
KERNEL := kernel-bin
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
- SUPPORTED_DEVICES = $$(DEVICE_DTS)
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
endef
#uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-define Device/am335x-evm
+define Device/ti_am335x-evm
DEVICE_TITLE := TI AM335x EVM
DEVICE_DTS := am335x-evm
endef
-TARGET_DEVICES += am335x-evm
+TARGET_DEVICES += ti_am335x-evm
-define Device/am335x-boneblack
+define Device/ti_am335x-bone-black
DEVICE_TITLE := TI AM335x BeagleBone Black
DEVICE_DTS := am335x-boneblack
endef
-TARGET_DEVICES += am335x-boneblack
+TARGET_DEVICES += ti_am335x-bone-black
-define Device/omap4-panda
+define Device/ti_omap4-panda
DEVICE_TITLE := OMAP4 TI pandaboard
DEVICE_DTS := omap4-panda
DEVICE_PACKAGES := kmod-usb-net-smsc95xx
endef
-TARGET_DEVICES += omap4-panda
+TARGET_DEVICES += ti_omap4-panda
-define Device/omap3-beagle
+define Device/ti_omap3-beagle
DEVICE_TITLE := OMAP3 TI beagleboard
DEVICE_DTS := omap3-beagle
# beagleboard doesn't have a network interface, support most common usb net
@@ -75,6 +75,6 @@ define Device/omap3-beagle
kmod-usb-net-smsc95xx kmod-usb-net-dm9601-ether
endef
-TARGET_DEVICES += omap3-beagle
+TARGET_DEVICES += ti_omap3-beagle
$(eval $(call BuildImage))