aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2017-08-28 13:37:07 +0200
committerJohn Crispin <john@phrozen.org>2017-08-30 17:05:10 +0200
commit40213cc15469fe5953e3d586ecb5870a382ee1ea (patch)
tree4b9957a6ad21913ea2fedcacbdb720a997b552d3
parentca7933730681bf3a42261fdf045dc1d929cbee48 (diff)
downloadupstream-40213cc15469fe5953e3d586ecb5870a382ee1ea.tar.gz
upstream-40213cc15469fe5953e3d586ecb5870a382ee1ea.tar.bz2
upstream-40213cc15469fe5953e3d586ecb5870a382ee1ea.zip
kernel: update 4.9 to 4.9.45
Refreshed all patches Compiled & run-tested on targets: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.9/930-crashlog.patch4
-rw-r--r--target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch2
-rw-r--r--target/linux/ramips/patches-4.9/0070-weak_reordering.patch6
-rw-r--r--target/linux/ramips/patches-4.9/101-mt7621-timer.patch18
5 files changed, 13 insertions, 21 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 897c5a0fa4..da10076218 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
LINUX_VERSION-4.4 = .83
-LINUX_VERSION-4.9 = .44
+LINUX_VERSION-4.9 = .45
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
LINUX_KERNEL_HASH-4.4.83 = 5b5f0a0a6cdadcbe5e1c1c057470bb42880590fc97edee299fb1833d646856b4
-LINUX_KERNEL_HASH-4.9.44 = 44a6386150d843da8fe13363377972ab040cc710268033ac99f599d5ba8ce3a3
+LINUX_KERNEL_HASH-4.9.45 = 66e5d18dc79a59606b270a1e221a0a80ac09a9e5cd13b1a8b608c514ae15666d
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/generic/hack-4.9/930-crashlog.patch b/target/linux/generic/hack-4.9/930-crashlog.patch
index 15d5ef4d67..baa87b1b7f 100644
--- a/target/linux/generic/hack-4.9/930-crashlog.patch
+++ b/target/linux/generic/hack-4.9/930-crashlog.patch
@@ -318,7 +318,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#include <asm/sections.h>
#include <linux/io.h>
-@@ -499,6 +500,8 @@ static void __init_memblock memblock_ins
+@@ -495,6 +496,8 @@ static void __init_memblock memblock_ins
memblock_set_region_node(rgn, nid);
type->cnt++;
type->total_size += size;
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}
/**
-@@ -538,6 +541,8 @@ int __init_memblock memblock_add_range(s
+@@ -534,6 +537,8 @@ int __init_memblock memblock_add_range(s
type->regions[0].flags = flags;
memblock_set_region_node(&type->regions[0], nid);
type->total_size = size;
diff --git a/target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch b/target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
index a5d3a3db32..f3abf34a9f 100644
--- a/target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
+++ b/target/linux/generic/pending-4.9/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -5905,7 +5905,7 @@ static void __ref alloc_node_mem_map(str
+@@ -5909,7 +5909,7 @@ static void __ref alloc_node_mem_map(str
mem_map = NODE_DATA(0)->node_mem_map;
#if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
diff --git a/target/linux/ramips/patches-4.9/0070-weak_reordering.patch b/target/linux/ramips/patches-4.9/0070-weak_reordering.patch
index 5961c49f95..5a4b6cb668 100644
--- a/target/linux/ramips/patches-4.9/0070-weak_reordering.patch
+++ b/target/linux/ramips/patches-4.9/0070-weak_reordering.patch
@@ -1,7 +1,5 @@
-Index: linux-4.9.44/arch/mips/ralink/Kconfig
-===================================================================
---- linux-4.9.44.orig/arch/mips/ralink/Kconfig
-+++ linux-4.9.44/arch/mips/ralink/Kconfig
+--- a/arch/mips/ralink/Kconfig
++++ b/arch/mips/ralink/Kconfig
@@ -56,6 +56,7 @@ choice
select COMMON_CLK
select CLKSRC_MIPS_GIC
diff --git a/target/linux/ramips/patches-4.9/101-mt7621-timer.patch b/target/linux/ramips/patches-4.9/101-mt7621-timer.patch
index 9d02d0d754..552716a21d 100644
--- a/target/linux/ramips/patches-4.9/101-mt7621-timer.patch
+++ b/target/linux/ramips/patches-4.9/101-mt7621-timer.patch
@@ -1,7 +1,5 @@
-Index: linux-4.9.44/arch/mips/ralink/mt7621.c
-===================================================================
---- linux-4.9.44.orig/arch/mips/ralink/mt7621.c
-+++ linux-4.9.44/arch/mips/ralink/mt7621.c
+--- a/arch/mips/ralink/mt7621.c
++++ b/arch/mips/ralink/mt7621.c
@@ -18,6 +18,7 @@
#include <asm/mach-ralink/ralink_regs.h>
#include <asm/mach-ralink/mt7621.h>
@@ -69,10 +67,8 @@ Index: linux-4.9.44/arch/mips/ralink/mt7621.c
void prom_soc_init(struct ralink_soc_info *soc_info)
{
void __iomem *sysc = (void __iomem *) KSEG1ADDR(MT7621_SYSC_BASE);
-Index: linux-4.9.44/arch/mips/ralink/Kconfig
-===================================================================
---- linux-4.9.44.orig/arch/mips/ralink/Kconfig
-+++ linux-4.9.44/arch/mips/ralink/Kconfig
+--- a/arch/mips/ralink/Kconfig
++++ b/arch/mips/ralink/Kconfig
@@ -57,6 +57,7 @@ choice
select CLKSRC_MIPS_GIC
select HW_HAS_PCI
@@ -81,10 +77,8 @@ Index: linux-4.9.44/arch/mips/ralink/Kconfig
endchoice
choice
-Index: linux-4.9.44/arch/mips/ralink/timer-gic.c
-===================================================================
---- linux-4.9.44.orig/arch/mips/ralink/timer-gic.c
-+++ linux-4.9.44/arch/mips/ralink/timer-gic.c
+--- a/arch/mips/ralink/timer-gic.c
++++ b/arch/mips/ralink/timer-gic.c
@@ -12,6 +12,7 @@
#include <linux/of.h>
#include <linux/clk-provider.h>