aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-20 15:47:25 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-22 10:53:42 +0100
commit26f864451031da22893ef64fb58502a11f7244c6 (patch)
treeb7b5659f935a8019382db300978c2398b87469af
parent73c60ef239619784964e9a88c7a361ebd0c425c6 (diff)
downloadupstream-26f864451031da22893ef64fb58502a11f7244c6.tar.gz
upstream-26f864451031da22893ef64fb58502a11f7244c6.tar.bz2
upstream-26f864451031da22893ef64fb58502a11f7244c6.zip
kernel: bump 3.18 to 3.18.135
Refreshed all patches. Fixes: - CVE-2019-3819 - CVE-2019-7221 - CVE-2019-7222 Compile-tested on: adm5120 Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-3.18/204-module_strip.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 9c0d8f1a0c..a636dc991e 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,12 +2,12 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .134
+LINUX_VERSION-3.18 = .135
LINUX_VERSION-4.9 = .158
LINUX_VERSION-4.14 = .101
LINUX_VERSION-4.19 = .23
-LINUX_KERNEL_HASH-3.18.134 = 36bdd04cab3b6c824a4b7e32ae02503f437e0916d5a4ff04c90aa22da2749c2f
+LINUX_KERNEL_HASH-3.18.135 = d1853eb6e5438abb0b54d11478c0792554e39325d37a3f04b68f6c151ed8f8eb
LINUX_KERNEL_HASH-4.9.158 = 8c8a69f590e6f1103c949b45ff1bfd42c705388321f75e1520be3556f81375ef
LINUX_KERNEL_HASH-4.14.101 = 142ff7c51b001c66e9be134fcec2722f9a47b89879a18e6f65b09b4585cdb69a
LINUX_KERNEL_HASH-4.19.23 = 2d9b25678aac7f3f109c52e6266fb6ee89cc424b597518a2875874bacb8f130a
diff --git a/target/linux/generic/pending-3.18/204-module_strip.patch b/target/linux/generic/pending-3.18/204-module_strip.patch
index 2df7ba0134..dcad148792 100644
--- a/target/linux/generic/pending-3.18/204-module_strip.patch
+++ b/target/linux/generic/pending-3.18/204-module_strip.patch
@@ -123,7 +123,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
set_license(mod, get_modinfo(info, "license"));
--- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c
-@@ -1758,7 +1758,9 @@ static void read_symbols(char *modname)
+@@ -1760,7 +1760,9 @@ static void read_symbols(char *modname)
symname = remove_dot(info.strtab + sym->st_name);
handle_modversions(mod, &info, sym, symname);
@@ -133,7 +133,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}
if (!is_vmlinux(modname) ||
(is_vmlinux(modname) && vmlinux_section_warnings))
-@@ -1902,7 +1904,9 @@ static void add_header(struct buffer *b,
+@@ -1904,7 +1906,9 @@ static void add_header(struct buffer *b,
buf_printf(b, "#include <linux/vermagic.h>\n");
buf_printf(b, "#include <linux/compiler.h>\n");
buf_printf(b, "\n");
@@ -143,7 +143,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
buf_printf(b, "\n");
buf_printf(b, "__visible struct module __this_module\n");
buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
-@@ -1919,16 +1923,20 @@ static void add_header(struct buffer *b,
+@@ -1921,16 +1925,20 @@ static void add_header(struct buffer *b,
static void add_intree_flag(struct buffer *b, int is_intree)
{
@@ -164,7 +164,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}
/**
-@@ -2021,11 +2029,13 @@ static void add_depends(struct buffer *b
+@@ -2023,11 +2031,13 @@ static void add_depends(struct buffer *b
static void add_srcversion(struct buffer *b, struct module *mod)
{
@@ -178,7 +178,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}
static void write_if_changed(struct buffer *b, const char *fname)
-@@ -2256,7 +2266,9 @@ int main(int argc, char **argv)
+@@ -2258,7 +2268,9 @@ int main(int argc, char **argv)
add_staging_flag(&buf, mod->name);
err |= add_versions(&buf, mod);
add_depends(&buf, mod, modules);