aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-06-20 11:10:18 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-06-20 15:48:48 +0200
commit1d34f99b1c0412a02955b10283e19cb903cc5b50 (patch)
tree86df501ccc23066bd73ac6c715b632b7423dc197
parent6592dddd1567817bcb07a5ec2bbed2876fe38c0c (diff)
downloadupstream-1d34f99b1c0412a02955b10283e19cb903cc5b50.tar.gz
upstream-1d34f99b1c0412a02955b10283e19cb903cc5b50.tar.bz2
upstream-1d34f99b1c0412a02955b10283e19cb903cc5b50.zip
kernel: bump 4.19 to 4.19.53
Refreshed all patches. Compile-tested on: imx6 Runtime-tested on: imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.19/930-crashlog.patch2
-rw-r--r--target/linux/generic/pending-4.19/834-ledtrig-libata.patch8
3 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 931fe571c7..cadfd5471c 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,11 +8,11 @@ endif
LINUX_VERSION-4.9 = .182
LINUX_VERSION-4.14 = .128
-LINUX_VERSION-4.19 = .52
+LINUX_VERSION-4.19 = .53
LINUX_KERNEL_HASH-4.9.182 = b16e12681a0638368479d73a9b1b8e9407c1ae4b7ae52fdf236d9e5657999695
LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
-LINUX_KERNEL_HASH-4.19.52 = 266ee655620c3689ae94761970d6827fffc919760caf815427ad22730ba4381e
+LINUX_KERNEL_HASH-4.19.53 = e647730b7eafac70c3bd7abed4e6ed5a09eb794c645fcb0c62a79f62edbdeb02
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/hack-4.19/930-crashlog.patch b/target/linux/generic/hack-4.19/930-crashlog.patch
index 890c72b640..0088b7a081 100644
--- a/target/linux/generic/hack-4.19/930-crashlog.patch
+++ b/target/linux/generic/hack-4.19/930-crashlog.patch
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
help
--- a/kernel/Makefile
+++ b/kernel/Makefile
-@@ -116,6 +116,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
+@@ -117,6 +117,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
obj-$(CONFIG_HAS_IOMEM) += iomem.o
obj-$(CONFIG_ZONE_DEVICE) += memremap.o
obj-$(CONFIG_RSEQ) += rseq.o
diff --git a/target/linux/generic/pending-4.19/834-ledtrig-libata.patch b/target/linux/generic/pending-4.19/834-ledtrig-libata.patch
index 70d3de05d0..de029fafe5 100644
--- a/target/linux/generic/pending-4.19/834-ledtrig-libata.patch
+++ b/target/linux/generic/pending-4.19/834-ledtrig-libata.patch
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
/**
* ata_build_rw_tf - Build ATA taskfile for given read/write request
* @tf: Target ATA taskfile
-@@ -5131,6 +5144,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5134,6 +5147,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
if (tag < 0)
return NULL;
}
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
qc = __ata_qc_from_tag(ap, tag);
qc->tag = qc->hw_tag = tag;
-@@ -6041,6 +6057,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6044,6 +6060,9 @@ struct ata_port *ata_port_alloc(struct a
ap->stats.unhandled_irq = 1;
ap->stats.idle_irq = 1;
#endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
ata_sff_port_init(ap);
return ap;
-@@ -6076,6 +6095,12 @@ static void ata_host_release(struct kref
+@@ -6079,6 +6098,12 @@ static void ata_host_release(struct kref
kfree(ap->pmp_link);
kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
kfree(ap);
host->ports[i] = NULL;
}
-@@ -6539,7 +6564,23 @@ int ata_host_register(struct ata_host *h
+@@ -6542,7 +6567,23 @@ int ata_host_register(struct ata_host *h
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
host->ports[i]->local_port_no = i + 1;
}